summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2016-09-30 13:40:16 +0200
committerThomas Kahle <tomka@gentoo.org>2016-09-30 13:45:53 +0200
commited656750c2d57ce9610a094ac22475c4b6c97bb9 (patch)
treeeb7f881c9b44f8862c87512b0a0aac01c3d4c6ef /sci-mathematics
parentx11-libs/libxcb: use proper phase for removing man pages. (diff)
downloadgentoo-ed656750c2d57ce9610a094ac22475c4b6c97bb9.tar.gz
gentoo-ed656750c2d57ce9610a094ac22475c4b6c97bb9.tar.bz2
gentoo-ed656750c2d57ce9610a094ac22475c4b6c97bb9.zip
sci-mathematics/polymake: Bump to 3.0r2
Also solves bug 595330 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/Manifest1
-rw-r--r--sci-mathematics/polymake/polymake-3.0_p2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/sci-mathematics/polymake/Manifest b/sci-mathematics/polymake/Manifest
index b4b030adde48..1528d820dc0f 100644
--- a/sci-mathematics/polymake/Manifest
+++ b/sci-mathematics/polymake/Manifest
@@ -1,3 +1,4 @@
DIST polymake-2.13-1.tar.bz2 16539798 SHA256 d010edc206b22356333493e90bd24f807c7341730232276d47dbf1b62eb53aba SHA512 90fd0c7eacbb673734e08860a753f75dae06347ce8affcb5d50c55a51975b85260db841393979c0143be5a71a26b6737f9513509d75a5950b40654c54d0be3ea WHIRLPOOL cef5c95930c7633acb0652e6ce3cd6c85b469af912ad1adb695e58a018e4cedbdac9f63caaeb12f3da0a8f7fb2b71e853b782f308a1594cfc89d2c9697e6c170
DIST polymake-2.14-minimal.tar.bz2 1996581 SHA256 c43b525c6f329ae2d8eb6d0e2af63f7846c4e5d408627665a28d0f421bbbcf9b SHA512 8989a8d2eb42c03e46569eca24334083154ff5107d7cd7d9dc481790b1553acd38025bd48ca016407e5c08b4b08f8062e19a1d4828ef535f83292510bdf5cd07 WHIRLPOOL 3f1521c60eafcff60b8ab2a443ff051835ee1c667eefcd59b33227e7a84293ccaefad4bc05eea4b8c541dea513b85b4e8538b6b572d762f2e1167b733029ec54
DIST polymake-2.14.tar.bz2 38747874 SHA256 c181277b5cd45ac00f5667647e4eb5fa13c20547623fd6e63ce2522c058883c2 SHA512 f66eac2e821060719a16a6979fa0cc20edf9598d425ba2fff5bddfc053fd582b05a5579e1c2521fd382733a4808955aa49cb946234a183aba3ef75eed8c02b22 WHIRLPOOL 26b21d28d6b9a76b7a3164b6d5e45a00ed8a604b3f973a22db1472dce714dec5f8ad5d2ee7133321e2cd0f48d6380343b8e6d93db9e79b6726ef1e9954c04405
+DIST polymake-3.0r2.tar.bz2 37695790 SHA256 e7c0f8e3a45ea288d2fb4ae781a1dcea913ef9c275fed401632cdb11a672d6dc SHA512 b4c22b2c6da8ef597dc05a44a30c7a55fd924a96854cde3f725095465972eabe1e24508f8e5d544f3131c82c973117b15983c38a0242fc7f1d4a4a8ecddb1d46 WHIRLPOOL 5a236ac32de0dd19e7f0f5b8b1b42f2b72fa2392ee098718383a8dfd0f1d1db3946d5f4f75bd9e4c075033deebcd87ddbb28ce70733d6371fa4624b8b6a4edd1
diff --git a/sci-mathematics/polymake/polymake-3.0_p2.ebuild b/sci-mathematics/polymake/polymake-3.0_p2.ebuild
new file mode 100644
index 000000000000..fc6475d9809f
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-3.0_p2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="https://polymake.org/lib/exe/fetch.php/download/polymake-3.0r2.tar.bz2"
+HOMEPAGE="http://polymake.org"
+
+IUSE="+cdd lrs ppl bliss group +libnormaliz singular libpolymake"
+
+REQUIRED_USE="group? ( cdd lrs )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-lang/perl
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ ppl? ( dev-libs/ppl )
+ cdd? ( sci-libs/cddlib )
+ lrs? ( >=sci-libs/lrslib-051[gmp] )
+ bliss? ( sci-libs/bliss[gmp] )
+ group? ( dev-libs/boost:= )
+ libnormaliz? ( dev-libs/boost:= )
+ singular? ( >=sci-mathematics/singular-4.0.1 )"
+RDEPEND="${DEPEND}
+ dev-perl/XML-LibXML
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+
+S="${WORKDIR}/${PN}-3.0"
+
+pkg_pretend() {
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+
+ # We need to define BLISS_USE_GMP if bliss was built with gmp support.
+ # Therefore we require gmp support on bliss, so that the package
+ # manager can prevent rebuilds with changed gmp flag.
+ if use bliss ; then
+ append-cxxflags -DBLISS_USE_GMP
+ fi
+
+ # Configure does not accept --host, therefore econf cannot be used
+
+ # Some of the options do not support using just '--with-option'
+ local myconf=""
+ use !group && myconf="$myconf --without-group"
+ use !libnormaliz && myconf="$myconf --without-libnormaliz"
+ use !libpolymake && myconf="$myconf --without-callable"
+
+ # And many other --with-arguments expect a path: --with-option=/path
+ ./configure --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
+ --without-prereq \
+ --without-java \
+ $(use_with cdd cdd "${EPREFIX}/usr") \
+ $(use_with lrs lrs "${EPREFIX}/usr") \
+ $(use_with ppl ppl "${EPREFIX}/usr") \
+ $(use_with bliss bliss "${EPREFIX}/usr") \
+ $(use_with singular singular "${EPREFIX}/usr") \
+ ${myconf} || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install
+}
+
+pkg_postinst(){
+ elog "Docs can be found on http://www.polymake.org/doku.php/documentation"
+ elog " "
+ elog "Support for jreality is missing, sorry (see bug #346073)."
+ elog " "
+ elog "Additional features for polymake are available through external"
+ elog "software such as sci-mathmatics/4ti2 and sci-mathematics/topcom."
+ elog "After installing new external software run 'polymake --reconfigure'."
+}