summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-05-06 17:40:09 +0200
committerDavid Seifert <soap@gentoo.org>2016-05-08 00:31:48 +0200
commit87fb055e1198f9f343c3f2991154f323d7187e60 (patch)
tree8286168a326e0af4a72604f940b8787bd9e7b4b6 /sci-misc/boinc
parentnet-analyzer/net-snmp: First package found so far that breaks with Perl 5.24 (diff)
downloadgentoo-87fb055e1198f9f343c3f2991154f323d7187e60.tar.gz
gentoo-87fb055e1198f9f343c3f2991154f323d7187e60.tar.bz2
gentoo-87fb055e1198f9f343c3f2991154f323d7187e60.zip
sci-misc/boinc: Fix VSYSCALL check for boinc-7.2.42
Gentoo-Bug: 578750 The configuration options were misunderstood. - CONFIG_X86_VSYSCALL_EMULATION only enables a dmesg message if any legacy application tries to use any vsyscall. If disabled, these applications simply segfault with no output in dmesg. - To make the old calls available, either CONFIG_LEGACY_VSYSCALL_NATIVE or CONFIG_LEGACY_VSYSCALL_EMULATE must be used. Therefore the ebuild was reverted to check against the CONFIG_LEGACY_VSYSCALL_NONE option, and warns the user if this is set. Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.2.42-r2.ebuild (renamed from sci-misc/boinc/boinc-7.2.42-r1.ebuild)34
1 files changed, 13 insertions, 21 deletions
diff --git a/sci-misc/boinc/boinc-7.2.42-r1.ebuild b/sci-misc/boinc/boinc-7.2.42-r2.ebuild
index ae58b2db6e07..a7c9d0606c82 100644
--- a/sci-misc/boinc/boinc-7.2.42-r1.ebuild
+++ b/sci-misc/boinc/boinc-7.2.42-r2.ebuild
@@ -50,32 +50,24 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
pkg_setup() {
+ # Bug 578750
if use kernel_linux; then
linux-info_pkg_setup
if ! linux_config_exists; then
ewarn "Can't check the linux kernel configuration."
ewarn "You might be missing vsyscall support."
- else
- if kernel_is -ge 4 4 \
- && linux_chkconfig_present LEGACY_VSYSCALL_NONE \
- && ! linux_chkconfig_present X86_VSYSCALL_EMULATION; then
- ewarn "You do have neither x86 vsyscall emulation"
- ewarn "nor legacy vsyscall support enabled."
- ewarn "This will prevent some boinc projects from running."
- ewarn "Please enable vsyscall emulation:"
- ewarn " CONFIG_X86_VSYSCALL_EMULATION=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " [*] Enable vsyscall emulation"
- ewarn "or set"
- ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " vsyscall table for legacy applications (None) --->"
- ewarn " (X) Emulate"
- ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
- ewarn "However, this has security implications and is not recommended."
- fi
+ elif kernel_is -ge 4 4 \
+ && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+ ewarn "You do not have vsyscall emulation enabled."
+ ewarn "This will prevent some boinc projects from running."
+ ewarn "Please enable vsyscall emulation:"
+ ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
+ ewarn "in /usr/src/linux/.config, to be found at"
+ ewarn " Processor type and features --->"
+ ewarn " vsyscall table for legacy applications (None) --->"
+ ewarn " (X) Emulate"
+ ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
+ ewarn "However, this has security implications and is not recommended."
fi
fi
}