summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-12-16 06:41:14 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2015-12-16 06:42:39 -0700
commite1eb41069d51ee1799b0ccd48474041fca80c146 (patch)
tree8f3370a6d249c7f72fcb569d57bbb623ecca3ad7 /sci-physics/lammps
parentnet-ftp/pure-ftpd: Revbump to add libressl support (bug #565392). (diff)
downloadgentoo-e1eb41069d51ee1799b0ccd48474041fca80c146.tar.gz
gentoo-e1eb41069d51ee1799b0ccd48474041fca80c146.tar.bz2
gentoo-e1eb41069d51ee1799b0ccd48474041fca80c146.zip
sci-physics/lammps: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'sci-physics/lammps')
-rw-r--r--sci-physics/lammps/Manifest1
-rw-r--r--sci-physics/lammps/lammps-20151207.ebuild217
2 files changed, 218 insertions, 0 deletions
diff --git a/sci-physics/lammps/Manifest b/sci-physics/lammps/Manifest
index c6b1c2d05dc4..2545b3bd93b7 100644
--- a/sci-physics/lammps/Manifest
+++ b/sci-physics/lammps/Manifest
@@ -11,4 +11,5 @@ DIST lammps-31Oct15.tar.gz 90163112 SHA256 c9f50531ddd720cc4aa469f74a8c528b91934
DIST lammps-4Sep15.tar.gz 87259558 SHA256 8652c801e4ce8b6b7d42a6c71f76b68a6e741dc8efb8d7d3dad36b624fe8f150 SHA512 ee730c8bd96e14931192a68c12e4ebde301cc3525b20816d051059f155b70c6edcea7dc2ed911e0b89685d751cd5a74b4bb5eedd6c16a042a2191bf8a9665fc9 WHIRLPOOL 271ac0d74e03d3e3e118a8b2385d98ce3f566ead67f1c329a219c265f886dc267b11be17c2caa52749ebac212bbc7456fba2d0d6ec69cd25815316e601b3360a
DIST lammps-5Oct15.tar.gz 88451532 SHA256 a76f92ae05b99f9257abf7d79d9365c5743fa5a16b941a5e40f74036c5879211 SHA512 e0a034778cd5e3b9a27c9fc6257f1f7a6a9161732cd83bac2c4b0f82c39d5a6a385bb4640322478bfbe9467afb28b998cd19108b3d4a21e369b80c39a486e065 WHIRLPOOL 291e7820d4736421aeda9a1295854bd7b52d8ca3f14900e9394373410ee5db02ad6ab53991cf4dc8e73328b24fa44659d10693aca7cb48301227299ad622ce31
DIST lammps-6Nov15.tar.gz 90177074 SHA256 b908d87106e89aa813c3d1a2e89f297ab42471ee463ef950f87f284d62aa24ac SHA512 91f8e33a00b3605dbb78f622a19886c11ca8ef3f4babe74e8d8f90bb176d5689e75d619155f58e6754a2756d20c05b74389e34f024167cba1841b8aade171daf WHIRLPOOL 4541537ea73292648764d6c8a7560f3127b8f911f4dcff0a97735c8e75868dc3aec7c2b32a2928ea446e8cfec87c81c9f86a635d29f3a65f42fd27661725911e
+DIST lammps-7Dec15.tar.gz 82168656 SHA256 7fa1bb1089437c0f38f8c6920286e2f8424e6449956b4d570da2954f507af1e7 SHA512 13078e7614402efc310a178506134409b40fb2768c4d7ee1cfa6992b247ef25169288ec99d4314b1a98125037d7c1c954bd114abc6ac41c58f60506358d150e2 WHIRLPOOL f9ba52c0c93ea6950b2ee7e0f5e15ebef6ea50f647d23cb2f9a1caf523d3dfb8d52adbdf8f8840eebd7f79fc59ab294310b7bf7109b27c6b7e9d6e7d2f18b7ee
DIST lammps-9Sep15.tar.gz 87275742 SHA256 c783be8bf2c2fbef75522b09b4420006d94104f2a60b82f55f7bc255c6163079 SHA512 60fa8c818c72c3c236095c7aa23c2ec30cc3370b6dc14d0c1d9e347772e70c96dab43019092eb93f2327377f1b4cc642416be65d156b1faf934bfa805d228bcf WHIRLPOOL 4a9dbb0f1b493177614646dcef124c723a3b6171d0894fee8b34e9fff7d0962ada0a2a27564338fef6551aaff322f4b50784b98c250555173cba5478cc60e9af
diff --git a/sci-physics/lammps/lammps-20151207.ebuild b/sci-physics/lammps/lammps-20151207.ebuild
new file mode 100644
index 000000000000..e692e6fc4cb5
--- /dev/null
+++ b/sci-physics/lammps/lammps-20151207.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+ local months=( "" Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec )
+ echo ${months[${1#0}]}
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+DEPEND="
+ mpi? (
+ virtual/blas
+ virtual/lapack
+ virtual/mpi
+ )
+ gzip? ( app-arch/gzip )
+ sci-libs/voro++
+ python? ( ${PYTHON_DEPS} )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+ local LAMMPS_INCLUDEFLAGS
+ LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+ LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"
+
+ # The lammps makefile uses CC to indicate the C++ compiler.
+ emake \
+ ARCHIVE="$(tc-getAR)" \
+ CC="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ F90="$(usex mpi "mpif90" "$(tc-getFC)")" \
+ LINK="$(usex mpi "mpic++" "$(tc-getCXX)")" \
+ CCFLAGS="${CXXFLAGS}" \
+ F90FLAGS="${FCFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+ MPI_INC="$(usex mpi "" "-I../STUBS")" \
+ MPI_PATH="$(usex mpi "" "-L../STUBS")" \
+ MPI_LIB="$(usex mpi "" "-lmpi_stubs")" \
+ user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+ "$@"
+}
+
+lmp_activate_packages() {
+ # Build packages
+ local packages=( yes-asphere yes-body yes-class2 yes-colloid \
+ yes-coreshell yes-dipole yes-fld yes-granular yes-kspace \
+ yes-manybody yes-mc yes-meam yes-misc \
+ $(usex mpi "yes-user-atc" "") \
+ yes-molecule yes-opt yes-peri yes-poems yes-qeq yes-reax \
+ yes-replica yes-rigid yes-shock yes-snap yes-srd \
+ yes-user-eff yes-user-fep \
+ $(usex mpi "yes-user-lb" "") \
+ yes-user-phonon yes-user-sph yes-voronoi yes-xtc )
+
+ for p in ${packages[@]}; do
+ lmp_emake -C src ${p}
+ done
+}
+
+lmp_build_packages() {
+ lmp_emake -C lib/meam -j1 -f Makefile.gfortran
+ lmp_emake -C lib/poems -f Makefile.g++
+ lmp_emake -C lib/reax -j1 -f Makefile.gfortran
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++
+}
+
+lmp_clean_packages() {
+ lmp_emake -C lib/meam -f Makefile.gfortran clean
+ lmp_emake -C lib/poems -f Makefile.g++ clean
+ lmp_emake -C lib/reax -f Makefile.gfortran clean
+ use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
+}
+
+src_prepare() {
+ # Fix inconsistent use of SHFLAGS.
+ sed -i \
+ -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+ -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+ lib/voronoi/Makefile.lammps || die
+
+ # Fix missing .so name.
+ sed -i \
+ -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+ src/MAKE/Makefile.serial || die
+
+ # Fix makefile in tools.
+ sed -i \
+ -e 's:g++:$(CXX) $(CXXFLAGS):' \
+ -e 's:gcc:$(CC) $(CCFLAGS):' \
+ -e 's:ifort:$(FC) $(FCFLAGS):' \
+ tools/Makefile || die
+
+ # Patch python.
+ epatch "${FILESDIR}/lammps-python3-r1.patch"
+ epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+ # Fix atc...
+ append-cxxflags -I../../src
+
+ # Acticate packages.
+ elog "Activating lammps packages..."
+ lmp_activate_packages
+
+ # STUBS/mpi.c is using '#include <mpi.h>' now instead of '#include
+ # "mpi.h"' which requires an additional '-I.'.
+ append-cxxflags -I.
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ if use static-libs; then
+ # Build static library.
+ elog "Building static library..."
+ lmp_emake -C src mode=lib serial
+ fi
+
+ # Clean out packages (that's not done by the build system with the clean
+ # target), so we can rebuild the packages with -fPIC.
+ elog "Cleaning packages..."
+ lmp_clean_packages
+
+ # The build system does not rebuild the packages with -fPIC, adding flag
+ # manually.
+ append-cxxflags -fPIC
+ append-fflags -fPIC
+
+ # Compile stubs for serial version.
+ use mpi || lmp_emake -C src mpi-stubs
+
+ elog "Building packages..."
+ lmp_build_packages
+
+ # Build shared library.
+ elog "Building shared library..."
+ lmp_emake -C src mode=shlib serial
+
+ # Compile main executable. The shared library is always built, and
+ # mode=shexe is simply a way to re-use the object files built in the
+ # "shlib" step when linking the executable. The executable is not actually
+ # using the shared library. If we have built the static library, then we
+ # link that into the executable.
+ elog "Linking executable..."
+ if use static-libs; then
+ lmp_emake -C src mode=exe serial
+ else
+ lmp_emake -C src mode=shexe serial
+ fi
+
+ # Compile tools.
+ elog "Building tools..."
+ lmp_emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+ use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+ newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+ dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+ newbin src/lmp_serial lmp
+ dobin tools/binary2txt
+ dobin tools/chain
+ dobin tools/data2xmovie
+ dobin tools/micelle2d
+ # Don't forget to add header files of optional packages as they are added
+ # to this ebuild. There may also be .mod files from Fortran based
+ # packages.
+ insinto "/usr/include/${PN}"
+ doins -r src/*.h lib/meam/*.mod
+
+ local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+ insinto "/${LAMMPS_POTENTIALS}"
+ doins potentials/*
+ echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+ doenvd 99lammps
+
+ # Install python script.
+ use python && python_foreach_impl python_domodule python/lammps.py
+
+ if use examples; then
+ local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+ insinto "${LAMMPS_EXAMPLES}"
+ doins -r examples/*
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/Manual.pdf
+ dohtml -r doc/*
+ fi
+}