summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-08-21 20:22:58 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-08-21 20:22:58 +0200
commit871c0ed9b8882a9705a36ef9fd887e768320231c (patch)
tree660034ab318c5cdd91a2a05be126da39627ae2c2 /sci-physics/rivet
parentdev-util/cmake: restore ppc keyword. (diff)
downloadgentoo-871c0ed9b8882a9705a36ef9fd887e768320231c.tar.gz
gentoo-871c0ed9b8882a9705a36ef9fd887e768320231c.tar.bz2
gentoo-871c0ed9b8882a9705a36ef9fd887e768320231c.zip
sci-physics/rivet: initial import from the science overlay
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-physics/rivet')
-rw-r--r--sci-physics/rivet/Manifest1
-rw-r--r--sci-physics/rivet/metadata.xml16
-rw-r--r--sci-physics/rivet/rivet-2.3.0.ebuild60
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
new file mode 100644
index 000000000000..6057c85a3211
--- /dev/null
+++ b/sci-physics/rivet/Manifest
@@ -0,0 +1 @@
+DIST Rivet-2.3.0.tar.bz2 2742948 SHA256 dd07702981d586e4b97b0fa56ae08cd08a631a952322a9b52e7622a46a7741ab SHA512 b51b77f80d69156dead899312cad838bc03479a072e163df50262e86790503515f8ab8af93723c3cbd33007d9812aa10581b2c960d92bc1fcf5031d27018d239 WHIRLPOOL ce9e5dd34ba9b53de192aee39bcd94565a62a328bd35dcb1ef810cc7b129e9ae6529fc8f970889f7a6970567bdd0f040d15fc5bbb83ec22e38daccb34cbb4fdf
diff --git a/sci-physics/rivet/metadata.xml b/sci-physics/rivet/metadata.xml
new file mode 100644
index 000000000000..306be1ac5d04
--- /dev/null
+++ b/sci-physics/rivet/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription>
+ The Rivet project (Robust Independent Validation of Experiment and
+ Theory) is a toolkit for validation of Monte Carlo event
+ generators. It provides a large (and ever growing) set of
+ experimental analyses useful for MC generator development,
+ validation, and tuning, as well as a convenient infrastructure for
+ adding your own analyses. Rivet is the most widespread way by which
+ analysis code from the LHC and other high-energy collider
+ experiments is preserved for comparison to and development of future
+ theory models.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-physics/rivet/rivet-2.3.0.ebuild b/sci-physics/rivet/rivet-2.3.0.ebuild
new file mode 100644
index 000000000000..4029c7394612
--- /dev/null
+++ b/sci-physics/rivet/rivet-2.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=Rivet-${PV}
+
+DESCRIPTION="Toolkit for validation of Monte Carlo HEP event generators"
+HOMEPAGE="http://rivet.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ sci-libs/gsl:0=
+ sci-physics/fastjet:0=[plugins]
+ sci-physics/hepmc:0=
+ sci-physics/yoda:0=[python]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex,dot] )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python pyext)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/Rivet/rivet-completion rivet
+ use doc && dohtml -r doxy/html/* && dodoc doc/rivet-manual.pdf
+}