summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-03-11 17:37:31 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-03-12 08:21:39 +0100
commit87d4e50ed08fec60ed9b9b9b18717d80f845c965 (patch)
treef849a1b21eaf61381ec28c2d99ca4c96ccd71793 /sci-physics
parentsci-physics/root: add new build options to configuration (diff)
downloadgentoo-87d4e50ed08fec60ed9b9b9b18717d80f845c965.tar.gz
gentoo-87d4e50ed08fec60ed9b9b9b18717d80f845c965.tar.bz2
gentoo-87d4e50ed08fec60ed9b9b9b18717d80f845c965.zip
sci-physics/root: add USE=mpi support
This is a new feature from ROOT 6.20.00 and later. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.20.00-r1.ebuild4
-rw-r--r--sci-physics/root/root-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sci-physics/root/root-6.20.00-r1.ebuild b/sci-physics/root/root-6.20.00-r1.ebuild
index d2fe9958e65c..9bb1b81ae15d 100644
--- a/sci-physics/root/root-6.20.00-r1.ebuild
+++ b/sci-physics/root/root-6.20.00-r1.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
- mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
+ mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
vmc +xml xrootd"
RESTRICT="!test? ( test )"
@@ -79,6 +79,7 @@ CDEPEND="
libcxx? ( sys-libs/libcxx )
unuran? ( sci-mathematics/unuran:0= )
minuit? ( !sci-libs/minuit )
+ mpi? ( virtual/mpi )
mysql? ( dev-db/mysql-connector-c )
odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
oracle? ( dev-db/oracle-instantclient-basic )
@@ -210,6 +211,7 @@ src_configure() {
-Dminuit=$(usex minuit)
-Dmlp=$(usex tmva)
-Dmonalisa=OFF
+ -Dmpi=$(usex mpi)
-Dmysql=$(usex mysql)
-Dodbc=$(usex odbc)
-Dopengl=$(usex opengl)
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index bc4a2339916b..172980d28a28 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="https://root.cern"
IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda cudnn +davix debug emacs
+examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
- mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
+ mpi mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
vmc +xml xrootd"
RESTRICT="!test? ( test )"
@@ -93,6 +93,7 @@ CDEPEND="
libcxx? ( sys-libs/libcxx )
unuran? ( sci-mathematics/unuran:0= )
minuit? ( !sci-libs/minuit )
+ mpi? ( virtual/mpi )
mysql? ( dev-db/mysql-connector-c )
odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
oracle? ( dev-db/oracle-instantclient-basic )
@@ -225,6 +226,7 @@ src_configure() {
-Dminuit=$(usex minuit)
-Dmlp=$(usex tmva)
-Dmonalisa=OFF
+ -Dmpi=$(usex mpi)
-Dmysql=$(usex mysql)
-Dodbc=$(usex odbc)
-Dopengl=$(usex opengl)