summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-19 09:33:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-19 09:33:57 +0200
commitd2049ce9200512f9cbeaa3bf7ee9fa47f845ca65 (patch)
treefac44df068916cbbac23a4305a9c60b788e799b1 /sci-physics
parentdev-python/gnome-python-base: Remove last-rited pkg (diff)
downloadgentoo-d2049ce9200512f9cbeaa3bf7ee9fa47f845ca65.tar.gz
gentoo-d2049ce9200512f9cbeaa3bf7ee9fa47f845ca65.tar.bz2
gentoo-d2049ce9200512f9cbeaa3bf7ee9fa47f845ca65.zip
sci-physics/espresso++: Remove last-rited pkg
Closes: https://bugs.gentoo.org/713568 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/Manifest1
-rw-r--r--sci-physics/espresso++/espresso++-2.0.2.ebuild61
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild61
-rw-r--r--sci-physics/espresso++/metadata.xml16
4 files changed, 0 insertions, 139 deletions
diff --git a/sci-physics/espresso++/Manifest b/sci-physics/espresso++/Manifest
deleted file mode 100644
index 00e12f47bebd..000000000000
--- a/sci-physics/espresso++/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST espresso++-2.0.2.tar.gz 26643776 BLAKE2B fb4756164f405472c922d4a0d64ad350a74315db96c9e846d1807e1b332c7fa8daa55831d5ee0baa31b4069e1f7c63a91e241e70913fdc5c31a77cc9514acaa4 SHA512 599bf0560eb8f9517f890f9f1895ec5a7d43b727e12f14e722506ad571f9d001f5cc54c3e91922954a7e7cefdaff85d5dd15cab58b35bf09f5399e22b42e588c
diff --git a/sci-physics/espresso++/espresso++-2.0.2.ebuild b/sci-physics/espresso++/espresso++-2.0.2.ebuild
deleted file mode 100644
index 151284b69afa..000000000000
--- a/sci-physics/espresso++/espresso++-2.0.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils python-r1
-
-DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
-HOMEPAGE="https://www.espresso-pp.de"
-
-MY_PN="${PN//+/p}"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- virtual/mpi
- dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
- sci-libs/fftw:3.0
- >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_configure() {
- src_configure_internal() {
- local mycmakeargs=(
- -DEXTERNAL_BOOST=ON
- -DEXTERNAL_MPI4PY=ON
- -DWITH_RC_FILES=OFF
- )
- cmake-utils_src_configure
- }
- python_foreach_impl src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
-}
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
deleted file mode 100644
index 151284b69afa..000000000000
--- a/sci-physics/espresso++/espresso++-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils python-r1
-
-DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
-HOMEPAGE="https://www.espresso-pp.de"
-
-MY_PN="${PN//+/p}"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- virtual/mpi
- dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
- sci-libs/fftw:3.0
- >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_configure() {
- src_configure_internal() {
- local mycmakeargs=(
- -DEXTERNAL_BOOST=ON
- -DEXTERNAL_MPI4PY=ON
- -DWITH_RC_FILES=OFF
- )
- cmake-utils_src_configure
- }
- python_foreach_impl src_configure_internal
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
-}
diff --git a/sci-physics/espresso++/metadata.xml b/sci-physics/espresso++/metadata.xml
deleted file mode 100644
index 1587252e7be8..000000000000
--- a/sci-physics/espresso++/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-physics@gentoo.org</email>
- <name>Gentoo Physics Project</name>
- </maintainer>
- <upstream>
- <remote-id type="bitbucket">espressopp/espressopp</remote-id>
- <remote-id type="github">espressopp/espressopp</remote-id>
- </upstream>
-</pkgmetadata>