summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-08-20 06:54:52 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-08-20 06:56:08 +0200
commitdae5155b70763d1cbd8f3b8732cc8d93ea62d910 (patch)
tree1cd10722bcfdb289fa49909a28b0f1fd5a3eb863 /sci-physics
parentdev-python/elasticsearch-py: add dep: doc? ( sphinx_rtd_theme ) (diff)
downloadgentoo-dae5155b70763d1cbd8f3b8732cc8d93ea62d910.tar.gz
gentoo-dae5155b70763d1cbd8f3b8732cc8d93ea62d910.tar.bz2
gentoo-dae5155b70763d1cbd8f3b8732cc8d93ea62d910.zip
sci-physics/yoda: initial import from the science overlay
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/metadata.xml16
-rw-r--r--sci-physics/yoda/yoda-1.4.0.ebuild51
3 files changed, 68 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
new file mode 100644
index 000000000000..4e6f6171a00d
--- /dev/null
+++ b/sci-physics/yoda/Manifest
@@ -0,0 +1 @@
+DIST YODA-1.4.0.tar.bz2 809432 SHA256 e76a129f7c2b72b53525fe0b712606eeeab0dc145daa070ebf0728f0384eaf48 SHA512 f1873888f3d2c28d42ac54fa9f3fa4a98e648a638ebceffce0a2f742c5fb6647fabd0de49c00407741e937600fc8a12d33ca26b8b9cd9b81c28a4d2e11f2bd3a WHIRLPOOL 6c8e0176b729d951351b3b9d574c91add5d6302aa76417241e560f3f3bbf38f4b60f41713d89a03a62b1c4ad3a98bd5342fd05901671e6aedf0c2c11dc36b024
diff --git a/sci-physics/yoda/metadata.xml b/sci-physics/yoda/metadata.xml
new file mode 100644
index 000000000000..b221b3a1213e
--- /dev/null
+++ b/sci-physics/yoda/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription>
+ Yet more Objects for Data Analysis is a small set of data analysis
+ (specifically histogramming) classes being developed by MCnet
+ members as a lightweight common system for MC event generator
+ validation analyses, particularly as the core histogramming system
+ in Rivet.
+</longdescription>
+<use>
+ <flag name="c++11"> Build using the C++11 standard</flag>
+ <flag name='root'>Adds support for <pkg>sci-physics/root</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/sci-physics/yoda/yoda-1.4.0.ebuild b/sci-physics/yoda/yoda-1.4.0.ebuild
new file mode 100644
index 000000000000..81c62f698900
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 autotools-utils bash-completion-r1
+
+MYP=YODA-${PV}
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="http://yoda.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${MYP}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="c++11 python root static-libs"
+
+RDEPEND="
+ dev-libs/boost:0=
+ python? ( ${PYTHON_DEPS} )
+ root? ( sci-physics/root:0=[python=,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable c++11 stdcxx11)
+ $(use_enable python pyext)
+ $(use_enable root)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newbashcomp "${ED}"/usr/share/YODA/yoda-completion yoda
+}