summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/xgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/xgraph')
-rw-r--r--sci-visualization/xgraph/Manifest3
-rw-r--r--sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch29
-rw-r--r--sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch12
-rw-r--r--sci-visualization/xgraph/metadata.xml14
-rw-r--r--sci-visualization/xgraph/xgraph-12.1-r2.ebuild44
-rw-r--r--sci-visualization/xgraph/xgraph-12.1-r3.ebuild41
6 files changed, 143 insertions, 0 deletions
diff --git a/sci-visualization/xgraph/Manifest b/sci-visualization/xgraph/Manifest
new file mode 100644
index 000000000000..08c6324624aa
--- /dev/null
+++ b/sci-visualization/xgraph/Manifest
@@ -0,0 +1,3 @@
+DIST xgraph-12.1.tar.gz 145278 SHA256 0aa17d3fa3abfa8b6679fc26812a988332a2a0f1f48973d17429089015672b08 SHA512 67c1faea0f423717cf97c4613e7c288ad17e952f7f0c7cc555d3d3cffaaef890b3b8d77f9421ab5842f8c65dea3393820e296b38d7a3eae2a0b80eb0b8fc948c WHIRLPOOL 16f5abba42e42196bed2994b2d83fb5a5266c4d0fdfa0b8bdd52f175f9046c09167544e93f45945cb1cf045319e725f9154c0ffdb9d8ac06eb4e8839a5c7cc3c
+DIST xgraph_12.1-10.diff.gz 48172 SHA256 5f0ee8dededaafb054b3d87431acc9b1b6486b8375775aac889d993e35f4e8d5 SHA512 060973645e5371a8f768650f31ad4560060ce171a9ee12308c5776a5e550784bb30cd3a55017c7a3856f27701376bb3f30af2c0b96d4902c89e68fd6c0114f78 WHIRLPOOL 0ea2a260005126d7c6f1fb9d3d335ec2cf6d7467b71441763d9a911055adc46d2805c1e9d32327c1762c2ad8fb6a290b5f579460ea0aa064ecba5e98f0337f83
+DIST xgraph_12.1-16.debian.tar.gz 23154 SHA256 a10daac6dca06938c4d96b8b82c8070b2763f6e0761030e0dfd2bb3fb338212a SHA512 6942d85d453a63191b11f6f52bee592c765023068d022e62b94b6fc6b0ed46ce57c9cc00bfcb53cd5f943997cef23724513c1433cdfbf11c7debac5760de1d26 WHIRLPOOL c6584cc98b0cf9e5cee85a4f1287dbb836aa7a0165d6c0c1d4066e0aefb4ce700d31e57d54cf8c051a5e1eb5e6c6410d1979b140628ea5ad90dbe1b2bc8fb336
diff --git a/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch b/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch
new file mode 100644
index 000000000000..e2514083c1d4
--- /dev/null
+++ b/sci-visualization/xgraph/files/xgraph-12.1-glibc-2.10.patch
@@ -0,0 +1,29 @@
+diff -ur xgraph-12.1.orig/dialog.c xgraph-12.1/dialog.c
+--- xgraph-12.1.orig/dialog.c 2009-08-09 01:02:01.000000000 +0300
++++ xgraph-12.1/dialog.c 2009-08-09 01:02:40.000000000 +0300
+@@ -775,7 +775,7 @@
+ memset(new_info->lines, 0, sizeof(Window) * E_LINES);
+
+ lineptr = text;
+- while (getline(&lineptr, line)) {
++ while (get_line(&lineptr, line)) {
+ if (new_info->num_lines >= new_info->alloc_lines) {
+ int old_alloc_lines_size = new_info->alloc_lines * sizeof(Window);
+ new_info->alloc_lines *= 2;
+@@ -886,7 +886,7 @@
+
+
+ int
+-getline(tptr, lptr)
++get_line(tptr, lptr)
+ char **tptr;
+ char *lptr;
+
+diff -ur xgraph-12.1.orig/dialog.h xgraph-12.1/dialog.h
+--- xgraph-12.1.orig/dialog.h 2009-08-09 01:02:01.000000000 +0300
++++ xgraph-12.1/dialog.h 2009-08-09 01:02:43.000000000 +0300
+@@ -1,3 +1,3 @@
+ extern void msg_box(char *, char *);
+-extern int getline(char **, char *);
++extern int get_line(char **, char *);
+ extern void do_error(char *);
diff --git a/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch b/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch
new file mode 100644
index 000000000000..e863742994d7
--- /dev/null
+++ b/sci-visualization/xgraph/files/xgraph-makefile-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur xgraph-12.1/Makefile.in xgraph-12.1-new/Makefile.in
+--- xgraph-12.1/Makefile.in 1999-12-20 16:40:32.000000000 -0500
++++ xgraph-12.1-new/Makefile.in 2006-08-12 10:04:18.000000000 -0400
+@@ -80,7 +80,7 @@
+
+ # C_WARNINGS = -Wall
+ C_WARNINGS =
+-CFLAGS = $(ADDITIONAL_INCLUDES) $(C_WARNINGS) -g $(X_CFLAGS)
++CFLAGS = $(ADDITIONAL_INCLUDES) $(C_WARNINGS) @CFLAGS@ $(X_CFLAGS)
+
+ xgraph_LDADD = $(ADDITIONAL_LIBS) $(X_LIBS) $(X_PRE_LIBS) $(X_EXTRA_LIBS) -lX11 -lm
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/sci-visualization/xgraph/metadata.xml b/sci-visualization/xgraph/metadata.xml
new file mode 100644
index 000000000000..96df77f1e460
--- /dev/null
+++ b/sci-visualization/xgraph/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Accepts data files or stdin in a form similar to the unix program
+ graph and displays line graphs, scatter plots, or bar charts on an
+ X11 display. Fully annotated with title, axis numbering and
+ labels, and legend. Zooming with the mouse is supported. Can
+ generate hardcopy output to Postscript printers and HPGL
+ plotters. Output can be directly pasted into idraw (drawtool) for
+ further annotation. Particularly useful in shell scripts.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/xgraph/xgraph-12.1-r2.ebuild b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
new file mode 100644
index 000000000000..566069fca92c
--- /dev/null
+++ b/sci-visualization/xgraph/xgraph-12.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils autotools
+
+DEB_PR=10
+DESCRIPTION="X11 Plotting Utility"
+HOMEPAGE="http://www.isi.edu/nsnam/xgraph/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
+
+LICENSE="xgraph"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples"
+DEPEND="x11-libs/libSM
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ # respect user flags
+ sed -i -e "s/-g/${CFLAGS}/" Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Compilation failed."
+ dodoc README*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Failed to install example files."
+ fi
+
+ dodir /usr/share/man/man1
+ mv "${ED}"/usr/share/man/manm/xgraph.man \
+ "${ED}"/usr/share/man/man1/xgraph.1 || \
+ die "Failed to correct man page location."
+ rm -Rf "${ED}"/usr/share/man/manm/ || \
+ die "Failed to remove bogus manm directory."
+}
diff --git a/sci-visualization/xgraph/xgraph-12.1-r3.ebuild b/sci-visualization/xgraph/xgraph-12.1-r3.ebuild
new file mode 100644
index 000000000000..dbcad563fa3b
--- /dev/null
+++ b/sci-visualization/xgraph/xgraph-12.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DEB_PR=16
+
+DESCRIPTION="X11 Plotting Utility"
+HOMEPAGE="http://www.isi.edu/nsnam/xgraph/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="xgraph"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples"
+DEPEND="x11-libs/libSM
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/debian-changes
+ rm configure.in Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc "${WORKDIR}"/debian/changelog
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ dodir /usr/share/man/man1
+ mv "${ED}"/usr/share/man/manm/xgraph.man \
+ "${ED}"/usr/share/man/man1/xgraph.1 || die
+ rm -r "${ED}"/usr/share/man/manm || die
+}