summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 01:05:03 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 10:46:52 +0100
commit893fcc63e06ffa3a0869fe466cbe962c19dd121e (patch)
tree2ccd8b64097ea3a5140f87f7c5b1b1d1e992feb5 /sci-visualization
parentdev-ruby/rubygems: add 3.0.1 (diff)
downloadgentoo-893fcc63e06ffa3a0869fe466cbe962c19dd121e.tar.gz
gentoo-893fcc63e06ffa3a0869fe466cbe962c19dd121e.tar.bz2
gentoo-893fcc63e06ffa3a0869fe466cbe962c19dd121e.zip
sci-visualization/spyview: Version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spyview/Manifest1
-rw-r--r--sci-visualization/spyview/spyview-2018.12.24.ebuild69
-rw-r--r--sci-visualization/spyview/spyview-9999.ebuild8
3 files changed, 71 insertions, 7 deletions
diff --git a/sci-visualization/spyview/Manifest b/sci-visualization/spyview/Manifest
index 4c8bca76ba0e..5a6c99d0cf4d 100644
--- a/sci-visualization/spyview/Manifest
+++ b/sci-visualization/spyview/Manifest
@@ -1,2 +1,3 @@
DIST spyview-20150124-patchset.tar.bz2 8268 BLAKE2B db7a710e2d61ad4f68e9dd31834f855b122b57fa532eb047a5efd7dd02423974f47652e4770144d02a317bf5a50c0ff852fd752ab331bad0c9efe237905916e0 SHA512 615465056df3786e18d5916dea0ad8ebd31c37ddf6531b85c080f53e0d9776c4f7519bd160ca8a0f29343b2f9fad40abef8d6b7194c4e54d6e2e14557562cc49
DIST spyview-20150124.tgz 14772947 BLAKE2B 18d3298e0498c4be91065c8651d379428541f3156ec7f2f0a6970ce5caafaa81da2ff6fbfcca42d77cfffedd293484aad19c7240ab9500e0cf7764cdb5e6ee4c SHA512 63c58c7729ceab9e1bfbb14b5d257a1d4ca51e43f7b014caffc8adf66767c17b47794b34cfc2f754c2905ff926302d66d438a582fe359a6c8d3e04b072993f5b
+DIST spyview-2018.12.24.tgz 15461336 BLAKE2B d88cea7a91b51a695bdc6eb4146b010b196cf24c2f21f16ef47782ed99f6f3b79d2950c35267ea71ac7a14705cb8ed8a4d1e12c03be0d5d8f6ad2f816c197c77 SHA512 b73837491650ccb9cc8f70e5a80700d33c05bbbf6914c778508ba1848db67b28cca0013e142def1f47755fb1370abfd850a55e4b69cca442ba43323029fb6d05
diff --git a/sci-visualization/spyview/spyview-2018.12.24.ebuild b/sci-visualization/spyview/spyview-2018.12.24.ebuild
new file mode 100644
index 000000000000..d43c86369ebe
--- /dev/null
+++ b/sci-visualization/spyview/spyview-2018.12.24.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="2D and 3D data visualization and analysis program"
+HOMEPAGE="https://github.com/gsteele13/spyview"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gsteele13/spyview.git"
+else
+ SRC_URI="https://github.com/gsteele13/spyview/archive/710b9ddb6aa00fada1a758d42b57b75f92bb32a7.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.62.0:=
+ media-libs/netpbm
+ x11-libs/fltk:1[opengl]
+ app-text/ghostscript-gpl
+ virtual/glu
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
+ S="${WORKDIR}/${P}/source"
+ else
+ default
+ mv -v "${WORKDIR}"/spyview-*/source "${S}" || die
+ fi
+}
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags)
+
+ append-cxxflags -std=c++14
+
+ append-cppflags -I"${EPREFIX}"/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+ append-ldflags -L$(dirname $(fltk-config --libs))
+
+ while IFS="" read -d $'\0' -r file; do
+ sed -i -e 's:-mwindows -mconsole::g' "$file" || die
+ done < <(find "${S}" -name Makefile.am -print0)
+
+ if [[ ${PV} == *9999* ]] ; then
+ eapply_user
+ else
+ default
+ fi
+ eautoreconf
+}
diff --git a/sci-visualization/spyview/spyview-9999.ebuild b/sci-visualization/spyview/spyview-9999.ebuild
index 8250f9599d4a..d43c86369ebe 100644
--- a/sci-visualization/spyview/spyview-9999.ebuild
+++ b/sci-visualization/spyview/spyview-9999.ebuild
@@ -12,8 +12,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gsteele13/spyview.git"
else
- SRC_URI="https://github.com/gsteele13/spyview/archive/966012afae2fbb77262bd96a7e530e81b0ed3b90.tar.gz -> $P.tgz
- https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2"
+ SRC_URI="https://github.com/gsteele13/spyview/archive/710b9ddb6aa00fada1a758d42b57b75f92bb32a7.tar.gz -> ${P}.tgz"
KEYWORDS="~amd64 ~x86"
fi
@@ -35,11 +34,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
sci-visualization/gnuplot"
-PATCHES=(
- "${WORKDIR}/${P}-patchset/${P}"-gnuplot_interface_fix.patch
- "${WORKDIR}/${P}-patchset/${P}"-gcc6cxx14-9.patch
-)
-
src_unpack() {
if [[ ${PV} == *9999* ]] ; then
git-r3_src_unpack