summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <cwprogram@live.com>2016-12-06 00:43:40 -0800
committerMatthias Maier <tamiko@gentoo.org>2017-01-26 13:06:12 -0600
commitbaa2918450ee90522af6d37bfd6aa6400da91735 (patch)
tree612365b36b6c5ca37d7c9e95793b26a7949b51cf /sci-visualization
parentsci-visualization/paraview: add glu depend (diff)
downloadgentoo-baa2918450ee90522af6d37bfd6aa6400da91735.tar.gz
gentoo-baa2918450ee90522af6d37bfd6aa6400da91735.tar.bz2
gentoo-baa2918450ee90522af6d37bfd6aa6400da91735.zip
sci-visualization/paraview: add -gles2 USE depend
After some research on a compilation error with the package maintainer it was determined that the build errors caused by having qtgui and qtopengl compiled with gles2 USE enabled were enough to warrant forcing a negated USE dep on both packages in the ebuild. Verified amd64 compilation without gles2 enabled qt packages Verified complaints when attempting to emerge the package with gles2 enabled qt packages
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/paraview-5.1.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-visualization/paraview/paraview-5.1.2-r1.ebuild b/sci-visualization/paraview/paraview-5.1.2-r1.ebuild
index 54d6d17e56a..00a491d5e02 100644
--- a/sci-visualization/paraview/paraview-5.1.2-r1.ebuild
+++ b/sci-visualization/paraview/paraview-5.1.2-r1.ebuild
@@ -48,7 +48,7 @@ RDEPEND="
coprocessing? (
plugins? (
dev-python/PyQt5
- dev-qt/qtgui:5
+ dev-qt/qtgui:5[-gles2]
)
)
ffmpeg? ( virtual/ffmpeg )
@@ -66,9 +66,9 @@ RDEPEND="
)
qt5? (
dev-qt/designer:5
- dev-qt/qtgui:5
+ dev-qt/qtgui:5[-gles2]
dev-qt/qthelp:5
- dev-qt/qtopengl:5
+ dev-qt/qtopengl:5[-gles2]
dev-qt/qtsql:5
dev-qt/qttest:5
dev-qt/qtwebkit:5