summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-03-26 10:54:52 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-03-26 10:55:05 +1100
commitdb2ad65b27a6ffe8e33e9fcd047feddec5e14f10 (patch)
tree89d42d38945f79ac99c7a067bea25b8642318591 /sys-apps/apparmor-utils/files
parentsys-libs/efivar: use bzip2 tarballs (diff)
downloadgentoo-db2ad65b27a6ffe8e33e9fcd047feddec5e14f10.tar.gz
gentoo-db2ad65b27a6ffe8e33e9fcd047feddec5e14f10.tar.bz2
gentoo-db2ad65b27a6ffe8e33e9fcd047feddec5e14f10.zip
sys-apps/apparmor-utils: revision bump adds binutils support
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-apps/apparmor-utils/files')
-rw-r--r--sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch b/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch
new file mode 100644
index 000000000000..3dce7c261688
--- /dev/null
+++ b/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch
@@ -0,0 +1,16 @@
+Avoid rewriting the shebang.
+
+The ebuild will take care of this when replicating the script for each of the
+supported python implementations.
+
+--- a/utils/python-tools-setup.py
++++ b/utils/python-tools-setup.py
+@@ -43,7 +43,7 @@
+ f = prefix + s
+ # If we have a defined python version, use it instead of the system
+ # default
+- if 'PYTHON' in os.environ:
++ if False:
+ lines = open(os.path.basename(s)).readlines()
+ lines[0] = '#! /usr/bin/env %s\n' % os.environ['PYTHON']
+ open(f, 'w').write("".join(lines))