summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2019-10-25 23:57:09 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-29 08:15:48 +0200
commit48af63861c961ad974d7cdbea4afdcb8fb23521c (patch)
treed35e180e96d4dd71cd112b046043025ba398555a /sys-apps/bleachbit/bleachbit-2.3.ebuild
parentsys-apps/bleachbit: Bump to 3.0 (diff)
downloadgentoo-48af63861c961ad974d7cdbea4afdcb8fb23521c.tar.gz
gentoo-48af63861c961ad974d7cdbea4afdcb8fb23521c.tar.bz2
gentoo-48af63861c961ad974d7cdbea4afdcb8fb23521c.zip
sys-apps/bleachbit: Remove old
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/13439 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps/bleachbit/bleachbit-2.3.ebuild')
-rw-r--r--sys-apps/bleachbit/bleachbit-2.3.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-apps/bleachbit/bleachbit-2.3.ebuild b/sys-apps/bleachbit/bleachbit-2.3.ebuild
deleted file mode 100644
index 903b5a3f45cb..000000000000
--- a/sys-apps/bleachbit/bleachbit-2.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit desktop distutils-r1
-
-DESCRIPTION="Clean junk to free disk space and to maintain privacy"
-HOMEPAGE="https://www.bleachbit.org"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+gtk"
-
-RDEPEND="
- dev-python/chardet[$PYTHON_USEDEP]
- dev-python/scandir[$PYTHON_USEDEP]
- gtk? ( dev-python/pygobject:3[$PYTHON_USEDEP] )
-"
-BDEPEND="
- dev-python/setuptools[$PYTHON_USEDEP]
- sys-devel/gettext
-"
-
-python_prepare_all() {
- # choose correct Python implementation, bug #465254
- sed -i 's/python/$(PYTHON)/g' po/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C po local
-}
-
-python_install() {
- distutils-r1_python_install
- python_newscript ${PN}.py ${PN}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- emake -C po DESTDIR="${D}" install
-
- # https://bugs.gentoo.org/388999
- insinto /usr/share/bleachbit/cleaners
- doins cleaners/*.xml
-
- insinto /usr/share/bleachbit
- doins data/app-menu.ui
-
- doicon ${PN}.png
- domenu ${PN}.desktop
-}