summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-26 21:44:08 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-26 22:00:17 +0300
commit1f90135f920d505dcd3bb67706233a7ea393cc5c (patch)
tree61b9a0679e53c077351ae781dde578c598b174e6 /sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild
parentx11-misc/appmenu-gtk-module: New Package (diff)
downloadgentoo-1f90135f920d505dcd3bb67706233a7ea393cc5c.tar.gz
gentoo-1f90135f920d505dcd3bb67706233a7ea393cc5c.tar.bz2
gentoo-1f90135f920d505dcd3bb67706233a7ea393cc5c.zip
sys-apps/osinfo-db-tools: bump to 1.8.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild')
-rw-r--r--sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild
new file mode 100644
index 000000000000..aa5926379ff7
--- /dev/null
+++ b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Blocker on old libosinfo as osinfo-db-validate was part of it before
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=app-arch/libarchive-3.0.0:=
+ net-libs/libsoup:2.4
+ >=dev-libs/libxml2-2.6.0
+ !<sys-libs/libosinfo-1.0.0
+"
+# perl dep is for pod2man (manpages)
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ use test && \
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/requests[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}