summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2023-11-28 09:48:34 +0100
committerSam James <sam@gentoo.org>2023-12-03 06:22:14 +0000
commite6bcf78ee22f45049aedc072d7032091c1e4ab70 (patch)
tree5c4bc29eadd1261177b419fe264316b7408eb537 /sys-apps/osinfo-db-tools
parentsys-libs/libosinfo: Fix build with >=dev-libs/libxml2-2.12.0 (diff)
downloadgentoo-e6bcf78ee22f45049aedc072d7032091c1e4ab70.tar.gz
gentoo-e6bcf78ee22f45049aedc072d7032091c1e4ab70.tar.bz2
gentoo-e6bcf78ee22f45049aedc072d7032091c1e4ab70.zip
sys-apps/osinfo-db-tools: Add 1.11.0
Unfortunately, libxml2 fixes missed the release and thus we need to carry them over. Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/osinfo-db-tools')
-rw-r--r--sys-apps/osinfo-db-tools/Manifest1
-rw-r--r--sys-apps/osinfo-db-tools/osinfo-db-tools-1.11.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db-tools/Manifest b/sys-apps/osinfo-db-tools/Manifest
index ad21a11d115f..3f844b15691a 100644
--- a/sys-apps/osinfo-db-tools/Manifest
+++ b/sys-apps/osinfo-db-tools/Manifest
@@ -1 +1,2 @@
DIST osinfo-db-tools-1.10.0.tar.xz 60508 BLAKE2B 2b9abbdba25add96440e2a937ae994c0305f995b924ffc7c88c2c31c122d3e5cf0c710fbf55724bea56f63be7250321ee27d2179e3f247461d6843f7e03dfc58 SHA512 27271b15404a6cb0065854ba8556c272cf3427ff4fd18fc9a22dbca2b01686c32661b24e18f5eff9a1b240a3a459d8fe66cbde530873d60b8c850bdd0b42c475
+DIST osinfo-db-tools-1.11.0.tar.xz 64792 BLAKE2B fc085da5bad46c5c178bdd09cc294c8f0f208cbd3ee4dda9e22bd681cac70913bc4dc9a11d44d252b5d7cb33b8a5625aca7c285ae098f72839e5fe4d2238c157 SHA512 adab5b16d8fcbae89619eb12f669fa4c7765a65af54a864995e3a9131bb18ee62568c8f7ed166f0400e5e622f56844ba53ed9ef5c2322e33acb9ef1cf0c94701
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.11.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.11.0.ebuild
new file mode 100644
index 000000000000..49f4ca477a35
--- /dev/null
+++ b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.11.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=app-arch/libarchive-3.0.0:=
+ net-libs/libsoup:3.0
+ >=dev-libs/libxml2-2.6.0
+"
+# perl dep is for pod2man (manpages)
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.0-no-clobber-fortify-source.patch
+ "${FILESDIR}"/${PN}-1.11.0-Make-xmlError-structs-constant.patch
+ "${FILESDIR}"/${PN}-1.11.0-osinfo-db-validate-Add-more-libxml-includes.patch
+)
+
+python_check_deps() {
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" && \
+ python_has_version "dev-python/requests[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}