summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2018-08-22 23:37:24 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-08 17:11:08 -0700
commitcbdbdff39f9d2f0781fb14eb1aaa112b6580fd54 (patch)
tree2867861b8c2fb51db47ec21a3627ed1253f99712 /sys-apps/s6-linux-utils
parentsys-apps/s6-portable-utils: Bump to 2.2.1.2 (diff)
downloadgentoo-cbdbdff39f9d2f0781fb14eb1aaa112b6580fd54.tar.gz
gentoo-cbdbdff39f9d2f0781fb14eb1aaa112b6580fd54.tar.bz2
gentoo-cbdbdff39f9d2f0781fb14eb1aaa112b6580fd54.zip
sys-apps/s6-linux-utils: Bump to 2.5.0.0
Bump EAPI to 7. Closes: https://github.com/gentoo/gentoo/pull/9675 Signed-off-by: Luis Ressel <aranea@aixah.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/s6-linux-utils')
-rw-r--r--sys-apps/s6-linux-utils/Manifest1
-rw-r--r--sys-apps/s6-linux-utils/s6-linux-utils-2.5.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/s6-linux-utils/Manifest b/sys-apps/s6-linux-utils/Manifest
index d9b28619f3f2..78bbb4320350 100644
--- a/sys-apps/s6-linux-utils/Manifest
+++ b/sys-apps/s6-linux-utils/Manifest
@@ -1 +1,2 @@
DIST s6-linux-utils-2.4.0.2.tar.gz 40832 BLAKE2B 24ce6d51aacfcaeeb8531931a0deac4e2430f627907157022ed6378e7058afcc946f1c620bb3758e43a1911db517dd46e65a43f338c446e61711b000d6751523 SHA512 4b0c8f1b65b8eb47f3aa7aa365d20dcd46fc144e166f78825ee53aeb789e009b2716a826efa1e92e86e8fe86421efc6ae07970ce421c6913f0b1db679eb6117e
+DIST s6-linux-utils-2.5.0.0.tar.gz 34976 BLAKE2B ccbe5a24c39d32a6d3e9c1ba09c76c278ed33e831ba9d124e30615204f4084823efd13500b2b2a0efa0ddd703996ec3a47ea66a2b5c1f832d8003cffccf6b773 SHA512 0433fd7863135629d2ab849db34c77f0cbc146f7a84833fcb9263d49ed8366f370f0513bb055990e40a17dff69a1b83a741b1bac2fc8d159d866b45a6b81bdc9
diff --git a/sys-apps/s6-linux-utils/s6-linux-utils-2.5.0.0.ebuild b/sys-apps/s6-linux-utils/s6-linux-utils-2.5.0.0.ebuild
new file mode 100644
index 000000000000..cbebf69605fa
--- /dev/null
+++ b/sys-apps/s6-linux-utils/s6-linux-utils-2.5.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="set of tiny linux utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-linux-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND="static? ( >=dev-libs/skalibs-2.7.0.0[static-libs] )
+ !static? ( >=dev-libs/skalibs-2.7.0.0 )
+"
+RDEPEND="!static? ( >=dev-libs/skalibs-2.7.0.0:= )"
+
+HTML_DOCS="doc/*"
+
+src_prepare() {
+ default
+
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
+
+ # configure overrides gentoo's -fstack-protector default
+ sed -i "/^tryflag CFLAGS -fno-stack-protector$/d" "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc)
+}