summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-07-22 18:28:12 +0800
committerJason Zaman <perfinion@gentoo.org>2017-07-22 18:46:08 +0800
commit76337f2d7d98fe190371b26ba866945a783cec75 (patch)
tree55bd86dc8d155c4be0231d9cd0ecf5b0771a4b28 /sys-apps/selinux-python
parentsys-apps/policycoreutils: bump to 2.7_rc5 (diff)
downloadgentoo-76337f2d7d98fe190371b26ba866945a783cec75.tar.gz
gentoo-76337f2d7d98fe190371b26ba866945a783cec75.tar.bz2
gentoo-76337f2d7d98fe190371b26ba866945a783cec75.zip
sys-apps/selinux-python: bump to 2.7_rc5
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-apps/selinux-python')
-rw-r--r--sys-apps/selinux-python/Manifest1
-rw-r--r--sys-apps/selinux-python/selinux-python-2.7_rc5.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 4bc9e3d348f5..db8f2130d336 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,2 +1,3 @@
DIST selinux-python-2.7-rc1.tar.gz 2067791 SHA256 29aa4b914a11f54c05670d09a92327cc1fe5203af41ec5ece837a7fc3f5563ac SHA512 8d0f774dd04b52d404cfdd0ed3bab7d83269a7881ff8a4f1170292193cdccb2cdbdc9456dd473fdaaa2b63584bfe0385e76a0e2315f6a9298dc5cf1c7b928c0f WHIRLPOOL 37ba7397a5523d1ed283d3d4d71e8643040d3b5ab37c90e64aed90d1190bca53480c3c034512ffda62b8494386bc1759013190fa4699befa4aee86d561e7a67c
DIST selinux-python-2.7-rc4.tar.gz 2067797 SHA256 e6e1ae9aaebc7450f470df807b8a3913d751f15ce555c39b6bc4a50a712cc0ad SHA512 f7a9c9ff0af4c127afdf4feae169b143d90f6c9883e678a79dce84b5807d697e778e44a709d1eddc927c48ba44315c8218262b96669661f3efa6e9c495b8cf4c WHIRLPOOL 781cd09f06c5bc153f8dc4892d10e08436b9da975a5951530f237a857d493ab6507dc56f6aa0c9f253c3bd92ace3dc23c1b9607ed4ba8c83816c0facc703ec8a
+DIST selinux-python-2.7-rc5.tar.gz 2067809 SHA256 05821b09514276a26f0d71959ba8a78e8a4a7d890300063a7f0f8822e448ee72 SHA512 69f62c04dbbe87acd0650c547cf7f23dd321f885b3d054d1265bf4c7c30c030f857cd681bb6c3a8e21d0b9532ec8ba0b10d80a90efe41cd8b2a575e2625d6372 WHIRLPOOL d2774e4c825f4d950d3fe156169a0e4211b0dd6dd33fbf3f3b461b20009e218e15d91b6ff3aafe2200acdf76053c059370752d25d58d4261db42324290eed249
diff --git a/sys-apps/selinux-python/selinux-python-2.7_rc5.ebuild b/sys-apps/selinux-python/selinux-python-2.7_rc5.ebuild
new file mode 100644
index 000000000000..07aa078e5b63
--- /dev/null
+++ b/sys-apps/selinux-python/selinux-python-2.7_rc5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 toolchain-funcs
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20170718"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+SEMNG_VER="${PV}"
+
+IUSE="audit pam dbus"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
+ >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
+ >=sys-libs/libsepol-${SEPOL_VER}:=
+ >=app-admin/setools-4.0
+ dev-python/ipy[${PYTHON_USEDEP}]
+ !dev-python/sepolgen
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+
+ python_copy_sources
+}
+
+src_compile() {
+ building() {
+ emake -C "${BUILD_DIR}" \
+ CC="$(tc-getCC)" \
+ PYLIBVER="${EPYTHON}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+ }
+ python_foreach_impl building
+}
+
+src_install() {
+ installation() {
+ emake -C "${BUILD_DIR}" \
+ DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
+ install
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ # Set version-specific scripts
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage; do
+ python_replicate_script "${ED}/usr/sbin/${pyscript}"
+ done
+
+ # Create sepolgen.conf with different devel location definition
+ if [[ -f /etc/selinux/config ]];
+ then
+ local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
+ mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ local selinuxtype="${POLICY_TYPES%% *}";
+ if [[ -n "${selinuxtype}" ]];
+ then
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
+ else
+ echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
+ fi
+ fi
+}