summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-01 21:03:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-01 21:06:18 +0000
commit28c5dc0f9fc2bd2a2cbe8db0d398a3407f350ec4 (patch)
treead1c05f511e349b07bba0ea5a296f68bd9db4de7 /sys-apps/sparc-utils
parentx11-plugins/wmtz: remove unused patches (diff)
downloadgentoo-28c5dc0f9fc2bd2a2cbe8db0d398a3407f350ec4.tar.gz
gentoo-28c5dc0f9fc2bd2a2cbe8db0d398a3407f350ec4.tar.bz2
gentoo-28c5dc0f9fc2bd2a2cbe8db0d398a3407f350ec4.zip
sys-apps/sparc-utils: bump debian patchset, refresh EAPI=6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/sparc-utils')
-rw-r--r--sys-apps/sparc-utils/Manifest1
-rw-r--r--sys-apps/sparc-utils/files/sparc-utils-1.9-no-implicit.patch21
-rw-r--r--sys-apps/sparc-utils/sparc-utils-1.9-r5.ebuild61
3 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/sparc-utils/Manifest b/sys-apps/sparc-utils/Manifest
index 4611687355c8..c796e304cd27 100644
--- a/sys-apps/sparc-utils/Manifest
+++ b/sys-apps/sparc-utils/Manifest
@@ -1,2 +1,3 @@
DIST sparc-utils_1.9-3.diff.gz 10337 BLAKE2B 03ee7ca15c4e736955fa08c66bbd1db2ec39764b4334fbec3838f5bcea3945d22c7a3148c00ab43a67324827af473739d014d7a6a895dbbd58c43ba13cbb1efe SHA512 c6eba75261ffee55cc49e3da71ad3a2f12e04574158975c69db0bbd94d7c22ca4dec50f3140cf0bf9f35bb547865deca3cfd3e28e76c70b9173926bc0b8f34ee
+DIST sparc-utils_1.9-4.diff.gz 9083 BLAKE2B e4b16c26fe67be73d0fd3ad8e1e80b19356d5961abac344f28650e4d355cac9c557999591947391c41be88d819ebb703ae1ff177b4fbe0d9bea7a411a791821f SHA512 ef79dc480471117da3a778450b3a122eaf64fdee69d35ff30b301f2360ff5d76c6343ce37c25cc188891c1619809daa0595d01c6e85781ddd7ddf1713c8378b7
DIST sparc-utils_1.9.orig.tar.gz 110080 BLAKE2B 52f47c130fb8e24b0340589c846292fb2e4e9b211a10cddf52a7a63edd70673e2b7d05c2415e558c5f2d1235f33f4ae65b777d3f8b2cf2c50a601d1f0a7a941a SHA512 bde05f1a98211aaf502be6dfd757ddfb21c136cedbb46ca84a4539706c71901815c9d8bedfebc3800c7340634b32276197c75f92f9cc829e4f50c37d203e9358
diff --git a/sys-apps/sparc-utils/files/sparc-utils-1.9-no-implicit.patch b/sys-apps/sparc-utils/files/sparc-utils-1.9-no-implicit.patch
new file mode 100644
index 000000000000..567edd3c6113
--- /dev/null
+++ b/sys-apps/sparc-utils/files/sparc-utils-1.9-no-implicit.patch
@@ -0,0 +1,21 @@
+diff --git a/prtconf-1.3/eeprom.c b/prtconf-1.3/eeprom.c
+index b801f95..b15e74c 100644
+--- a/prtconf-1.3/eeprom.c
++++ b/prtconf-1.3/eeprom.c
+@@ -33,4 +33,6 @@
+ #include <dirent.h>
+ #include <pwd.h>
++#include <ctype.h> /* isdigit() */
++#include <sys/ioctl.h> /* ioctl() */
+
+ #include <asm/openpromio.h>
+diff --git a/prtconf-1.3/prtconf.c b/prtconf-1.3/prtconf.c
+index b9d8c89..c9b54be 100644
+--- a/prtconf-1.3/prtconf.c
++++ b/prtconf-1.3/prtconf.c
+@@ -30,4 +30,5 @@
+ #include <sys/stat.h>
+ #include <sys/utsname.h>
++#include <sys/ioctl.h> /* ioctl() */
+
+ #include <asm/openpromio.h>
diff --git a/sys-apps/sparc-utils/sparc-utils-1.9-r5.ebuild b/sys-apps/sparc-utils/sparc-utils-1.9-r5.ebuild
new file mode 100644
index 000000000000..80f6a939f0df
--- /dev/null
+++ b/sys-apps/sparc-utils/sparc-utils-1.9-r5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Various sparc utilities from Debian GNU/Linux"
+HOMEPAGE="https://packages.debian.org/sparc-utils"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/s/${PN}/${PN}_${PV}-4.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~sparc"
+IUSE=""
+
+DEPEND="virtual/os-headers"
+RDEPEND=">=sys-apps/util-linux-2.13-r1"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=(
+ "${WORKDIR}/${PN}_${PV}-4.diff"
+ "${FILESDIR}"/${P}-no-implicit.patch
+)
+
+src_compile() {
+ emake -C elftoaout-2.3 \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake -C src piggyback piggyback64 \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake -C prtconf-1.3 all \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ # since the debian/piggyback64.1 manpage is a pointer to the
+ # debian/piggyback.1 manpage, copy debian/piggyback.1 to
+ # debian/piggyback64.1
+
+ cp "${S}"/debian/piggyback.1 "${S}"/debian/piggyback64.1 || die
+
+ dobin elftoaout-2.3/elftoaout
+ dobin src/piggyback
+ dobin src/piggyback64
+ dosbin prtconf-1.3/prtconf
+ dosbin prtconf-1.3/eeprom
+
+ doman elftoaout-2.3/elftoaout.1
+ doman prtconf-1.3/prtconf.8
+ doman prtconf-1.3/eeprom.8
+ doman debian/piggyback.1
+ doman debian/piggyback64.1
+}
+
+pkg_postinst() {
+ ewarn "In order to have /usr/sbin/eeprom, make sure you build /dev/openprom"
+ ewarn "device support (CONFIG_SUN_OPENPROMIO) into the kernel, or as a"
+ ewarn "module (and that the module is loaded)."
+}