summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-16 11:30:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-16 11:34:06 +0200
commit0c88fd4d16bd6407fe188e449b6b99549978427f (patch)
tree1f0f830a58bb2e366e433a06ad5660b8045a2b24 /sys-apps
parentgames-roguelike/nethack: Depend on acct-group/gamestat. (diff)
downloadgentoo-0c88fd4d16bd6407fe188e449b6b99549978427f.tar.gz
gentoo-0c88fd4d16bd6407fe188e449b6b99549978427f.tar.bz2
gentoo-0c88fd4d16bd6407fe188e449b6b99549978427f.zip
sys-apps/kbd: Bump to version 2.1.0
Closes: https://bugs.gentoo.org/661650 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.1.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index c23aeeba3b9d..eca4c0877c8b 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1 +1,2 @@
DIST kbd-2.0.4.tar.xz 1031864 BLAKE2B 10c2bded89befda1f1d7ab199796e082a4e3b2333cf29a2abbbe843191dce41a7289d5bc3b7e55d8b25c7144ae4b4977e4321b38896917d0083af8ddd4924a3e SHA512 5e264b3695b0af0bc85e0a4fa2c43e13648d8ea82102f3b051c28da2abfc52977577c470bce48f30cec9b0d215297e48c9b05e00561c990e3770fb68f6544e0f
+DIST kbd-2.1.0.tar.xz 1114896 BLAKE2B 273b1149ac1ba6220d786fa6fedf22432937c8e7a8c3317eecc11d4533a72f6c29566dda75be2fb0fae3c0f02d63a10e6207cbe96719051639fc661c859e1040 SHA512 bfb3e7c4ab2973bf68ee6ce8fd90b4e51cff5a466c04b375c1a6d9418319cf041a593edb4915637cd0c3b472614cd39d8184837d14e9177f163817da4e769849
diff --git a/sys-apps/kbd/kbd-2.1.0.ebuild b/sys-apps/kbd/kbd-2.1.0.ebuild
new file mode 100644
index 000000000000..12711a24eca6
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+
+RDEPEND="
+ app-arch/gzip
+ pam? (
+ !app-misc/vlock
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ cd "${S}"/data/keymaps/i386 || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+}
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ docinto html
+ dodoc docs/doc/*.html
+}