summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-18 11:50:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-18 15:06:21 +0200
commit2cd01ca8bdcbdc612b10b6b69b652ab2904a3574 (patch)
tree717c3a20df7f6d252d227cf5e0f58d143a7e1f65 /sys-apps
parentdev-libs/libsass: bump to 3.6.0 (diff)
downloadgentoo-2cd01ca8bdcbdc612b10b6b69b652ab2904a3574.tar.gz
gentoo-2cd01ca8bdcbdc612b10b6b69b652ab2904a3574.tar.bz2
gentoo-2cd01ca8bdcbdc612b10b6b69b652ab2904a3574.zip
sys-apps/util-linux: Fixed floating point exception in lscpu
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/files/util-linux-2.34_rc1-lscpu_floating_point_exception_fix.patch28
-rw-r--r--sys-apps/util-linux/util-linux-2.34_rc1.ebuild4
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/util-linux/files/util-linux-2.34_rc1-lscpu_floating_point_exception_fix.patch b/sys-apps/util-linux/files/util-linux-2.34_rc1-lscpu_floating_point_exception_fix.patch
new file mode 100644
index 000000000000..b1314e0e44c7
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.34_rc1-lscpu_floating_point_exception_fix.patch
@@ -0,0 +1,28 @@
+From 836455917879333e94d4a535aa22f1235b5d4885 Mon Sep 17 00:00:00 2001
+From: Sami Kerola <kerolasa@iki.fi>
+Date: Sat, 18 May 2019 10:19:35 +0100
+Subject: [PATCH] lscpu: fix floating point exception
+
+FIXME: this commit should include vmware_fpe regression test inclusion.
+
+Caused-by: e5f721132ec8b8c933a396d8dcb3efcb67854f13
+Addresses: https://github.com/karelzak/util-linux/issues/788
+Reported-by: Lars Wendler <polynomial-c@gentoo.org>
+Signed-off-by: Sami Kerola <kerolasa@iki.fi>
+---
+ sys-utils/lscpu.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/sys-utils/lscpu.c b/sys-utils/lscpu.c
+index ca7f6a037..7f6277f00 100644
+--- a/sys-utils/lscpu.c
++++ b/sys-utils/lscpu.c
+@@ -1925,6 +1925,8 @@ static int get_cache_full_size(struct lscpu_desc *desc,
+ /* Correction for CPU threads */
+ if (desc->nthreads > desc->ncores)
+ nshares /= (desc->nthreads / desc->ncores);
++ if (nshares < 1)
++ nshares = 1;
+
+ *res = (desc->ncores / nshares) * ca->size;
+ return 0;
diff --git a/sys-apps/util-linux/util-linux-2.34_rc1.ebuild b/sys-apps/util-linux/util-linux-2.34_rc1.ebuild
index 1c6fd4ea22a3..b222e422b0fa 100644
--- a/sys-apps/util-linux/util-linux-2.34_rc1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.34_rc1.ebuild
@@ -63,6 +63,10 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-lscpu_floating_point_exception_fix.patch
+)
+
src_prepare() {
default