summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-12-21 11:27:08 +0100
committerPatrick Lauer <patrick@gentoo.org>2015-12-21 11:27:08 +0100
commit486fe9995f841604d46b92689646edee5e6bb1a8 (patch)
treec70ff476bc68f97c1c37f2c250311d9ba8390efb /sys-apps
parentapp-shells/mksh: Bump (diff)
downloadgentoo-486fe9995f841604d46b92689646edee5e6bb1a8.tar.gz
gentoo-486fe9995f841604d46b92689646edee5e6bb1a8.tar.bz2
gentoo-486fe9995f841604d46b92689646edee5e6bb1a8.zip
sys-apps/toybox: Bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/toybox/Manifest1
-rw-r--r--sys-apps/toybox/toybox-0.6.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/toybox/Manifest b/sys-apps/toybox/Manifest
index 1a4d5a692a44..e4c65a7c77c2 100644
--- a/sys-apps/toybox/Manifest
+++ b/sys-apps/toybox/Manifest
@@ -5,3 +5,4 @@ DIST toybox-0.5.0.tar.bz2 564512 SHA256 2718b42154be041435df48d5b5140f4e307767c3
DIST toybox-0.5.1.tar.bz2 588987 SHA256 83baa69a26e03a920ea7e91fbeb9016178990450d4144d1a244275b44346a12c SHA512 4abab27ef1d3ecedc1b419ea7421c032bdb9bd375a808e8400eda6c409665b41f35bef959087b863bb661d54962fb8ce78ed1d74285040837611dfdb7c715d03 WHIRLPOOL 8b098073ca7a604205e6c1857fedacab1c42785281cd05fe76bb654a54fea77beb588d7f9bd575be9c2c12fe03ae6598ba2f31b683f1bafdf249d26b8b953df8
DIST toybox-0.5.2.tar.gz 685909 SHA256 dec7f6433ee0e130f224fc63760b347ad0572280c4de32f1aaefbee813a79a00 SHA512 76b20c70a1568b03c32e5670f8fbc517b4d528c21e74fc44ce1241cb494ad329f8e3412bf6501521ad2c19d07f89046fba2c37f8a07f4aba1e0ebe1346d9c83d WHIRLPOOL 168b2039c02fd8381a8c5c4353ed1d365a4ed941477b5b1acb21f6330d4f8e0785c69511edd187de790d0d6b65a9d34218a01ca25747558a0890f5f4c7f6f44b
DIST toybox-0.6.0.tar.gz 710572 SHA256 d0b9788f61b9f9cbc685eabc0bd89b6925201ecb15a0cb4fbbd5fbf658b99991 SHA512 ddbd2252cd64a3508b9cd9d8a0a574805583b5b9c3861c153d25e8a394115c28b5a58d02a5aa7d7f58b9b9f3effcd33ac3f55788e0f3c4ad4265233f49c6f3ff WHIRLPOOL 0a83bc9895fd0c43ac541afdbfb6caaa294639646c82e70090fd40b77cf5943009188bb8f1b12b1af82d9bb94dd345892b36a5f7849d7154d34efa0b1f1a5f17
+DIST toybox-0.6.1.tar.gz 736371 SHA256 122ceb30c6ca0e8b8e914a427b1aaa89715c53a3df500afc56524ce88426838c SHA512 256afdcb0303b8f7a0bfa411cd0300d45460229dac3bf86fa147bb9d7806dc1224d0b1e28e58472932d8468407491559c6369cb29e78f67691560825dc25a68a WHIRLPOOL 0a5194965d3b4f4521193a51523d59cd52f23999c95cf167234853004cb0c3503aa4df96e65ab1d524741ff8e1d47def8af072f7eb8e8d55caec9c24b5525039
diff --git a/sys-apps/toybox/toybox-0.6.1.ebuild b/sys-apps/toybox/toybox-0.6.1.ebuild
new file mode 100644
index 000000000000..71beeaa77fe1
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.6.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gfto/toybox.git"
+else
+ SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+ restore_config .config
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ tc-export CC STRIP
+ export HOSTCC=$(tc-getBUILD_CC)
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin toybox_unstripped toybox
+}