summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-27 17:12:59 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-27 17:14:06 -0500
commit7fb9d131211507009775a3a2ac2e4d4f4dc32b89 (patch)
tree819d8625b4828be2cd68f18a250e1a66295d413c /sys-apps
parentx11-misc/tint2: version bump 0.12.3 bug #565876.Thanks Anthony Parsons. (diff)
downloadgentoo-7fb9d131211507009775a3a2ac2e4d4f4dc32b89.tar.gz
gentoo-7fb9d131211507009775a3a2ac2e4d4f4dc32b89.tar.bz2
gentoo-7fb9d131211507009775a3a2ac2e4d4f4dc32b89.zip
sys-apps/findutils: version bump to 4.5.18
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/Manifest1
-rw-r--r--sys-apps/findutils/findutils-4.5.18.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index 06df4af7816f..9931b73970e9 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1,3 +1,4 @@
DIST findutils-4.4.2.tar.gz 2149838 SHA256 434f32d171cbc0a5e72cfc5372c6fc4cb0e681f8dce566a0de5b6fccd702b62a SHA512 262d0a8301158e6541b9f24e4e043d8d8c1b196b18dbe59c3bedcf17b50c95708e33ab23a07e3bfb947ad495faafffdca3c296fb525794ca60f2dfd682f228c1 WHIRLPOOL 2af1467403ece2f290be6b9f69db013d386427ab553efcf750ce36bf608fab0d37708209c22bf61b8a82f41aa13bf25a247c62f78dc95446290b7a4bd35d3393
DIST findutils-4.5.16.tar.gz 3869606 SHA256 d116b48cf2a90a457726f58e24842bfa6078447d0c53be0fd1593f2555f7caae SHA512 d03100ea0708448ac714e86b6bc8ae4d9667f46df1cf0d29e1cfad6f52656254a47a2dd7ef88aaa68f94f399e848cd9d0977e25eda3781cfcd20819dc9fa76d6 WHIRLPOOL d42c7028eccdb38229aa725fade1a6aa2b2a57a65f317ccff83cf3da5594463f7810c17cc10fa5ced89a4213780133a57fd61948dc5d03b300a57f927e103eb2
DIST findutils-4.5.17.tar.gz 3871981 SHA256 a41f171f0e05b6960ae1081dc21fb87f58bf939395d6559e297b59a493136a4f SHA512 a3f9a522e721e1d5c4d1b2839dcf85e829c531cb3eb63ec99765b0d5367c7a64b51ec4150e93be3fca5c620eebd3ca7a3bd7eee868663068658ee23b003bdd7a WHIRLPOOL da22ebab27435c32718d082a9991548745d13468558562590609e57478f586e7789a49e88138e9f23833189a4dc3d79fbbeaba8b3481f1cf812f1dd8a9db93b8
+DIST findutils-4.5.18.tar.gz 3870196 SHA256 e3b570534c7897e8de117396345e2e20f17f704389b7e1daa7889fd089afbdd7 SHA512 2ae70cef9aee81d4402298db11890efa0ec38dba561dfc11afc9c91af7c1c6a7cca221f669c45b00e65eba53a8b08f5124ed4e862d9e26bcf69c48a927e6b398 WHIRLPOOL ece27a2830792e162ca5e53d7d0fefa8959292b6945180a331ac4dc1a999bd858649f761a5dee44bb35e85ffa0dd633b1b65aeeb294ac4a8846ad1cdbfaf351e
diff --git a/sys-apps/findutils/findutils-4.5.18.ebuild b/sys-apps/findutils/findutils-4.5.18.ebuild
new file mode 100644
index 000000000000..8d96f1d0fe25
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils flag-o-matic toolchain-funcs python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls selinux static test"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ program_prefix=$(usex userland_GNU '' g)
+ econf \
+ --with-packager="Gentoo" \
+ --with-packager-version="${PVR}" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/" \
+ --program-prefix=${program_prefix} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ --libexecdir='$(libdir)'/find
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}