summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-12 09:52:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-12 09:52:36 +0100
commit97a0d0ae0af66fc9dbe869678ddd2ff763329ea5 (patch)
treee9a407fcf7729e310b9a96f8d5e5a3c8b0cec3ad /sys-apps
parentsys-apps/mlocate: Stable for all arches. (diff)
downloadgentoo-97a0d0ae0af66fc9dbe869678ddd2ff763329ea5.tar.gz
gentoo-97a0d0ae0af66fc9dbe869678ddd2ff763329ea5.tar.bz2
gentoo-97a0d0ae0af66fc9dbe869678ddd2ff763329ea5.zip
sys-apps/mlocate: Removed old.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mlocate/files/mlocate.cron-r248
-rw-r--r--sys-apps/mlocate/mlocate-0.26-r1.ebuild63
2 files changed, 0 insertions, 111 deletions
diff --git a/sys-apps/mlocate/files/mlocate.cron-r2 b/sys-apps/mlocate/files/mlocate.cron-r2
deleted file mode 100644
index cf42104a45a1..000000000000
--- a/sys-apps/mlocate/files/mlocate.cron-r2
+++ /dev/null
@@ -1,48 +0,0 @@
-#! /bin/sh
-set -e
-
-# check if we run on battery and if so then don't run
-if which on_ac_power >/dev/null 2>&1; then
- ON_BATTERY=0
- on_ac_power >/dev/null 2>&1 || ON_BATTERY=$?
- if [ "${ON_BATTERY}" -eq 1 ]; then
- exit 0
- fi
-fi
-
-# check if we are already running (lockfile)
-LOCKFILE="/var/lock/mlocate.daily.lock"
-if [ -e "${LOCKFILE}" ]; then
- echo >&2 "Warning: \"${LOCKFILE}\" already present, not running updatedb."
- exit 1
-fi
-touch "${LOCKFILE}"
-# trap the lockfile only if we really run the updatedb
-trap "rm -f ${LOCKFILE}" EXIT
-
-# source the user specified variables
-if [ -f /etc/mlocate-cron.conf ]; then
- . /etc/mlocate-cron.conf
-fi
-
-# check the config file
-NODEVS=""
-if [ ! -f /etc/updatedb.conf ]; then
- NODEVS=$(awk '$1 == "nodev" && $2 != "rootfs" { print $2 }' /proc/filesystems)
-fi
-
-# alter the priority of the updatedb process
-if [ -x /usr/bin/renice ]; then
- /usr/bin/renice +${NICE:-19} -p $$ > /dev/null 2>&1
-fi
-if [ -x /usr/bin/ionice ] && /usr/bin/ionice -c3 true 2>/dev/null; then
- /usr/bin/ionice -c${IONICE_CLASS:-2} -n${IONICE_PRIORITY:-7} -p $$ > /dev/null 2>&1
-fi
-
-# run the updatedb if possible
-if [ -x /usr/bin/updatedb ]; then
- /usr/bin/updatedb -f "${NODEVS}"
-else
- echo >&2 "Warning: \"/usr/bin/updatedb\" is not executable, unable to run updatedb."
- exit 0
-fi
diff --git a/sys-apps/mlocate/mlocate-0.26-r1.ebuild b/sys-apps/mlocate/mlocate-0.26-r1.ebuild
deleted file mode 100644
index a08956719e31..000000000000
--- a/sys-apps/mlocate/mlocate-0.26-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-inherit eutils user toolchain-funcs
-
-DESCRIPTION="Merging locate is an utility to index and quickly search for files"
-HOMEPAGE="https://fedorahosted.org/mlocate/"
-SRC_URI="https://fedorahosted.org/releases/m/l/mlocate/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls selinux"
-
-RDEPEND="!sys-apps/slocate
- !sys-apps/rlocate
- selinux? ( sec-policy/selinux-slocate )"
-DEPEND="app-arch/xz-utils
- nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
- enewgroup locate
-}
-
-src_configure() {
- econf $(use_enable nls)
-}
-
-src_compile() {
- emake groupname=locate AR="$(tc-getAR)"
-}
-
-src_install() {
- emake groupname=locate DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README NEWS
-
- insinto /etc
- doins "${FILESDIR}"/updatedb.conf
- doins "${FILESDIR}"/mlocate-cron.conf
- fperms 0644 /etc/{updatedb,mlocate-cron}.conf
-
- insinto /etc/cron.daily
- newins "${FILESDIR}"/mlocate.cron-r2 mlocate
- fperms 0755 /etc/cron.daily/mlocate
-
- fowners 0:locate /usr/bin/locate
- fperms go-r,g+s /usr/bin/locate
-
- keepdir /var/lib/mlocate
- chown -R 0:locate "${ED}"/var/lib/mlocate
- fperms 0750 /var/lib/mlocate
-}
-
-pkg_postinst() {
- elog "The database for the locate command is generated daily by a cron job,"
- elog "if you install for the first time you can run the updatedb command manually now."
- elog
- elog "Note that the /etc/updatedb.conf file is generic,"
- elog "please customize it to your system requirements."
-}