summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-10 09:07:19 +0100
committerSam James <sam@gentoo.org>2022-08-10 09:07:29 +0100
commita92a9f6ab23a9b1eee9b8486a71455c1907c7e92 (patch)
tree57b4f8b523be8eebc05e437a17e7b109c3ae041c /sys-apps
parentdev-util/ninja: Stabilize 1.11.0 ppc, #864573 (diff)
downloadgentoo-a92a9f6ab23a9b1eee9b8486a71455c1907c7e92.tar.gz
gentoo-a92a9f6ab23a9b1eee9b8486a71455c1907c7e92.tar.bz2
gentoo-a92a9f6ab23a9b1eee9b8486a71455c1907c7e92.zip
sys-apps/iproute2: fix musl build
Closes: https://bugs.gentoo.org/864771 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/files/iproute2-5.19.0-musl.patch48
-rw-r--r--sys-apps/iproute2/iproute2-5.19.0.ebuild1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-5.19.0-musl.patch b/sys-apps/iproute2/files/iproute2-5.19.0-musl.patch
new file mode 100644
index 000000000000..e907ba9454bf
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-5.19.0-musl.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/864771
+https://github.com/shemminger/iproute2/commit/cf6b60c504d4be5e1df2b2745e55d677967831d0
+https://github.com/shemminger/iproute2/commit/28c740473510cd911b97cc5d7d23bd809a0f200b
+
+From cf6b60c504d4be5e1df2b2745e55d677967831d0 Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Tue, 9 Aug 2022 04:01:05 +0000
+Subject: [PATCH] ipstats: Add param.h for musl
+
+Fix build error for musl
+| /usr/src/debug/iproute2/5.19.0-r0/iproute2-5.19.0/ip/ipstats.c:231: undefined reference to `MIN'
+
+Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
+--- a/ip/ipstats.c
++++ b/ip/ipstats.c
+@@ -1,6 +1,7 @@
+ // SPDX-License-Identifier: GPL-2.0+
+ #include <assert.h>
+ #include <errno.h>
++#include <sys/param.h>
+
+ #include "list.h"
+ #include "utils.h"
+
+From 28c740473510cd911b97cc5d7d23bd809a0f200b Mon Sep 17 00:00:00 2001
+From: Stephen Hemminger <stephen@networkplumber.org>
+Date: Tue, 9 Aug 2022 13:27:33 -0700
+Subject: [PATCH] ipstats: add missing headers
+
+IWYU reports several headers are not explicitly
+included by ipstats.
+
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+--- a/ip/ipstats.c
++++ b/ip/ipstats.c
+@@ -1,7 +1,11 @@
+ // SPDX-License-Identifier: GPL-2.0+
++#include <alloca.h>
+ #include <assert.h>
+ #include <errno.h>
++#include <stdio.h>
++#include <string.h>
+ #include <sys/param.h>
++#include <sys/socket.h>
+
+ #include "list.h"
+ #include "utils.h"
+
diff --git a/sys-apps/iproute2/iproute2-5.19.0.ebuild b/sys-apps/iproute2/iproute2-5.19.0.ebuild
index b3c0b0e984dc..0ad41a520dc0 100644
--- a/sys-apps/iproute2/iproute2-5.19.0.ebuild
+++ b/sys-apps/iproute2/iproute2-5.19.0.ebuild
@@ -51,6 +51,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
#"${FILESDIR}"/${PN}-5.1.0-portability.patch
"${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
+ "${FILESDIR}"/${P}-musl.patch
)
src_prepare() {