summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-12-29 23:34:56 -0800
committerZac Medico <zmedico@gentoo.org>2018-12-29 23:38:51 -0800
commitb737b77e6e0f8802c172d9424ed1f8942ea40d66 (patch)
tree319f72c319323d8de1f0151e6a39d729dca2a0b5 /sys-apps
parentdev-util/bcc: remove old version 0.5.0_p20171230 (diff)
downloadgentoo-b737b77e6e0f8802c172d9424ed1f8942ea40d66.tar.gz
gentoo-b737b77e6e0f8802c172d9424ed1f8942ea40d66.tar.bz2
gentoo-b737b77e6e0f8802c172d9424ed1f8942ea40d66.zip
sys-apps/portage: add linux-info check for namespace support
Bug: https://bugs.gentoo.org/673900 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index b1da4eee48b8..a483b5524449 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ PYTHON_COMPAT=(
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 git-r3 systemd
+inherit distutils-r1 git-r3 linux-info systemd
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -86,6 +86,12 @@ prefix_src_archives() {
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git
https://github.com/gentoo/portage.git"
+pkg_pretend() {
+ local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"
+
+ check_extra_config
+}
+
pkg_setup() {
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
}