summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-03 13:14:18 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-03 13:15:00 -0500
commitd8a4eca97c26279ab339be03dd587ff25644d851 (patch)
tree46c5238e319d4cdd537951b6652a94d1b0a08d9a /sys-apps
parentprofiles: Whitespace (diff)
downloadgentoo-d8a4eca97c26279ab339be03dd587ff25644d851.tar.gz
gentoo-d8a4eca97c26279ab339be03dd587ff25644d851.tar.bz2
gentoo-d8a4eca97c26279ab339be03dd587ff25644d851.zip
sys-apps/systemd: backport lz4 version check fix
226 does not check the version at all, so skip it. Bug: https://bugs.gentoo.org/595210 Package-Manager: Portage-2.3.3_p13, Repoman-2.3.1_p6
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/files/232-lz4-version.patch44
-rw-r--r--sys-apps/systemd/systemd-231.ebuild3
-rw-r--r--sys-apps/systemd/systemd-232.ebuild3
3 files changed, 48 insertions, 2 deletions
diff --git a/sys-apps/systemd/files/232-lz4-version.patch b/sys-apps/systemd/files/232-lz4-version.patch
new file mode 100644
index 000000000000..d99ceda7a7a9
--- /dev/null
+++ b/sys-apps/systemd/files/232-lz4-version.patch
@@ -0,0 +1,44 @@
+From 3d4cf7de48a74726694abbaa09f9804b845ff3ba Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Wed, 23 Nov 2016 10:18:30 -0500
+Subject: [PATCH] build-sys: check for lz4 in the old and new numbering scheme
+ (#4717)
+
+lz4 upstream decided to switch to an incompatible numbering scheme
+(1.7.3 follows 131, to match the so version).
+PKG_CHECK_MODULES does not allow two version matches for the same package,
+so e.g. lz4 < 10 || lz4 >= 125 cannot be used. Check twice, once for
+"new" numbers (anything below 10 is assume to be new), once for the "old"
+numbers (anything above >= 125). This assumes that the "new" versioning
+will not get to 10 to quickly. I think that's a safe assumption, lz4 is a
+mature project.
+
+Fixed #4690.
+---
+ configure.ac | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 65eaae1ae..5979de4dc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -621,10 +621,13 @@ AM_CONDITIONAL(HAVE_BZIP2, [test "$have_bzip2" = "yes"])
+ have_lz4=no
+ AC_ARG_ENABLE(lz4, AS_HELP_STRING([--disable-lz4], [disable optional LZ4 support]))
+ AS_IF([test "x$enable_lz4" != "xno"], [
+- PKG_CHECK_MODULES(LZ4, [ liblz4 >= 125 ],
+- [AC_DEFINE(HAVE_LZ4, 1, [Define in LZ4 is available])
++ PKG_CHECK_MODULES(LZ4, [ liblz4 < 10 ],
++ [AC_DEFINE(HAVE_LZ4, 1, [Define if LZ4 is available])
+ have_lz4=yes],
+- have_lz4=no)
++ [PKG_CHECK_MODULES(LZ4, [ liblz4 >= 125 ],
++ [AC_DEFINE(HAVE_LZ4, 1, [Define if LZ4 is available])
++ have_lz4=yes],
++ have_lz4=no)])
+ AS_IF([test "x$have_lz4" = xno -a "x$enable_lz4" = xyes],
+ [AC_MSG_ERROR([*** LZ4 support requested but libraries not found])])
+ ])
+--
+2.11.0
+
diff --git a/sys-apps/systemd/systemd-231.ebuild b/sys-apps/systemd/systemd-231.ebuild
index 1561160a017d..e27e74fc084d 100644
--- a/sys-apps/systemd/systemd-231.ebuild
+++ b/sys-apps/systemd/systemd-231.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -162,6 +162,7 @@ src_prepare() {
sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
local PATCHES=(
+ "${FILESDIR}/232-lz4-version.patch"
"${FILESDIR}/218-Dont-enable-audit-by-default.patch"
"${FILESDIR}/228-noclean-tmp.patch"
)
diff --git a/sys-apps/systemd/systemd-232.ebuild b/sys-apps/systemd/systemd-232.ebuild
index 431852f16811..d2e71ed73592 100644
--- a/sys-apps/systemd/systemd-232.ebuild
+++ b/sys-apps/systemd/systemd-232.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -150,6 +150,7 @@ src_prepare() {
sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
local PATCHES=(
+ "${FILESDIR}/232-lz4-version.patch"
)
if ! use vanilla; then