summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-03-30 06:22:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-03-30 06:22:43 -0400
commite69870431d5eaefa896ea4e6b324eade97e7f30e (patch)
treec90485509f51198207639a5d0c28e00274e53021 /sys-apps
parentmedia-libs/leptonica: Drop old 1.76.0 (diff)
downloadgentoo-e69870431d5eaefa896ea4e6b324eade97e7f30e.tar.gz
gentoo-e69870431d5eaefa896ea4e6b324eade97e7f30e.tar.bz2
gentoo-e69870431d5eaefa896ea4e6b324eade97e7f30e.zip
sys-apps/install-xattr: version bump to 0.6, address bug #681866
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/install-xattr/Manifest1
-rw-r--r--sys-apps/install-xattr/install-xattr-0.6.ebuild46
-rw-r--r--sys-apps/install-xattr/install-xattr-9999.ebuild7
3 files changed, 51 insertions, 3 deletions
diff --git a/sys-apps/install-xattr/Manifest b/sys-apps/install-xattr/Manifest
index 384a60d13cc6..d3a88c6c4723 100644
--- a/sys-apps/install-xattr/Manifest
+++ b/sys-apps/install-xattr/Manifest
@@ -1 +1,2 @@
DIST install-xattr-0.5.tar.bz2 16136 BLAKE2B 8973584d4819b9f500dcfb76ed0eaddce725b78e72dfa73ccff52c745e6f041926f8f930e5c5035fa888402c6b530207546098864266268dee2c897404bf7c74 SHA512 0bbde3a548fc5062041b38f90ac09c402f3cb0aebf4f0c331552fc44d39dd3d5e4d73bca0811de36c53af8afa5d22e543a7c90107d272f2a1b97c819b244eb7c
+DIST install-xattr-0.6.tar.bz2 16207 BLAKE2B 2f771aa3e81d594eda951ae34242ecf658e18d72f2cb4c8540ab8af40af750e50ad881c44476af84bb05c3ced9df052f08ea8f81ce490f250010e74b190bd1d9 SHA512 1af66ac8ea05b4c32b905f5d5e340e0402fd19d9f5c2fa51c32d0842effafded8327fce58adffdd197b47c0d4d90f8b669c309f512b64e90f86adc7afe995bcf
diff --git a/sys-apps/install-xattr/install-xattr-0.6.ebuild b/sys-apps/install-xattr/install-xattr-0.6.ebuild
new file mode 100644
index 000000000000..2da2f9601445
--- /dev/null
+++ b/sys-apps/install-xattr/install-xattr-0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ default
+ tc-export CC
+ append-cppflags "-D_FILE_OFFSET_BITS=64"
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ DESTDIR=${ED} emake install
+}
+
+# We need to fix how tests are done
+src_test() {
+ true
+}
diff --git a/sys-apps/install-xattr/install-xattr-9999.ebuild b/sys-apps/install-xattr/install-xattr-9999.ebuild
index 830b2d6cd4f9..2da2f9601445 100644
--- a/sys-apps/install-xattr/install-xattr-9999.ebuild
+++ b/sys-apps/install-xattr/install-xattr-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
@@ -23,6 +23,7 @@ SLOT="0"
src_prepare() {
default
tc-export CC
+ append-cppflags "-D_FILE_OFFSET_BITS=64"
}
src_compile() {