summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-06 10:25:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-06 10:25:20 +0200
commitfcba13ad2baeff8a99b86127cf4fa9a334b37e20 (patch)
tree33469618252b8acd0d8e000fa3c218e6b2844e86 /sys-apps
parentsys-apps/fbset: add types patch for musl, update EAPI and copyright date (diff)
downloadgentoo-fcba13ad2baeff8a99b86127cf4fa9a334b37e20.tar.gz
gentoo-fcba13ad2baeff8a99b86127cf4fa9a334b37e20.tar.bz2
gentoo-fcba13ad2baeff8a99b86127cf4fa9a334b37e20.zip
sys-apps/man-db: Bump to version 2.8.3
Closes: https://bugs.gentoo.org/650384 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man-db/Manifest1
-rw-r--r--sys-apps/man-db/man-db-2.8.3.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/sys-apps/man-db/Manifest b/sys-apps/man-db/Manifest
index b15f0dbb4d85..3b02bc38f871 100644
--- a/sys-apps/man-db/Manifest
+++ b/sys-apps/man-db/Manifest
@@ -1,3 +1,4 @@
DIST man-db-2.7.6.1.tar.xz 1541316 BLAKE2B ea3aa7e90ea8af4882bd99d99374cc37d9c0c7f70bb970973eb3f2178aa4323bcdebc7f39f142ec0144dbe55a9f86aba15d9fe281d2662d280b8e6dca9452f24 SHA512 623c5e7f8b7c289908b2c926f8777293b8d39aeceef0d2509d701a8b0bfa81408650f655c8608318221786c751a79ee91124b07993de5298cd7fa6d8bb737301
DIST man-db-2.8.1.tar.xz 1621664 BLAKE2B 94496c1ca912e7cea2c98be8443d5b13dd685c5af86e9996b625fae44384f4cacf24a4196d77a080da10baa385b5e63d8b090c2bfcc492f2a41757d7a3840468 SHA512 82e75df32eb8575f47c3f36b5f2bbc827776747abfa39af589802e6566636c0771df0ee3197cb2bec3318c3055ff4e9d04c7da13b3bc6ea8a1ea1b1340554ef0
DIST man-db-2.8.2.tar.xz 1622504 BLAKE2B fc551838488323914319cde2b4d0d724be63741a1e0ed816a67a26da89dfa84a7faf99a9aba20e0e254129aa0f26505b76f4ba6be6786281c4d105e96829e9ee SHA512 ffd6c3ba605da419c819dcad10edf713242074a035ce405f4c97dbbd2a7e9b253f82efae1022d08d9f04591014e752ff38a3f8727e5a5cf60d33a9167cc2d8fc
+DIST man-db-2.8.3.tar.xz 1624280 BLAKE2B 6158608a5a6ecd361391a17642a4bbc9275a8a3105a39d6f6c3971aceb275cfb16670c51dfa8f1d7fc0136fc1b5e96e39c88e8c1d91e9a47d7a1351d16623a93 SHA512 35d5dda7a2bda94978d10770d24d4c78b3c62c71a68cfeb400df61b0df289ed17aa8aa223d4ae3ffa094d76df8d9172b878230fd7b0397ce7728b9c8ac0b1745
diff --git a/sys-apps/man-db/man-db-2.8.3.ebuild b/sys-apps/man-db/man-db-2.8.3.ebuild
new file mode 100644
index 000000000000..627b8941479e
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.8.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune user versionator
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/man-db.git"
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb +gdbm +manpager nls seccomp selinux static-libs zlib"
+
+CDEPEND="
+ !sys-apps/man
+ >=dev-libs/libpipeline-1.5.0
+ sys-apps/groff
+ berkdb? ( sys-libs/db:= )
+ gdbm? ( sys-libs/gdbm:= )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm:= ) )
+ seccomp? ( sys-libs/libseccomp )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? (
+ >=app-text/po4a-0.45
+ sys-devel/gettext
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-mandb )
+"
+PDEPEND="manpager? ( app-text/manpager )"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+
+ if (use gdbm && use berkdb) || (use !gdbm && use !berkdb) ; then #496150
+ ewarn "Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings"
+ fi
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ --with-systemdtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ --enable-setuid
+ --enable-cache-owner=man
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x"
+ $(use_enable nls)
+ $(use_enable static-libs static)
+ $(use_with seccomp libseccomp)
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+ )
+ econf "${myeconfargs[@]}"
+
+ # Disable color output from groff so that the manpager can add it. #184604
+ sed -i \
+ -e '/^#DEFINE.*\<[nt]roff\>/{s:^#::;s:$: -c:}' \
+ src/man_db.conf || die
+}
+
+src_install() {
+ default
+ dodoc docs/{HACKING,TODO}
+ prune_libtool_files
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/man-db.cron man-db #289884
+}
+
+pkg_preinst() {
+ local cachedir="${EROOT}var/cache/man"
+ # If the system was already exploited, and the attacker is hiding in the
+ # cachedir of the old man-db, let's wipe them out.
+ # see bug #602588 comment 18
+ local _replacing_version=
+ local _setgid_vuln=0
+ for _replacing_version in ${REPLACING_VERSIONS}; do
+ if version_is_at_least '2.7.6.1-r2' "${_replacing_version}"; then
+ debug-print "Skipping security bug #602588 ... existing installation (${_replacing_version}) should not be affected!"
+ else
+ _setgid_vuln=1
+ debug-print "Applying cleanup for security bug #602588"
+ fi
+ done
+ [[ ${_setgid_vuln} -eq 1 ]] && rm -rf "${cachedir}"
+
+ # Fall back to recreating the cachedir
+ if [[ ! -d ${cachedir} ]] ; then
+ mkdir -p "${cachedir}" || die
+ chown man:man "${cachedir}" || die
+ fi
+
+ # Update the whatis cache
+ if [[ -f ${cachedir}/whatis ]] ; then
+ einfo "Cleaning ${cachedir} from sys-apps/man"
+ find "${cachedir}" -type f '!' '(' -name index.bt -o -name index.db ')' -delete
+ fi
+}
+
+pkg_postinst() {
+ if [[ $(get_version_component_range 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
+ einfo "Rebuilding man-db from scratch with new database format!"
+ mandb --quiet --create
+ fi
+}