summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-12-15 15:50:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2015-12-15 15:54:39 -0600
commit0f49ad4562ee3ceae9f9e4d32aefcf5bd2953b29 (patch)
treea018d7d388cdb2231ff29f748484f4d47e7cf241 /sys-auth/keystone/keystone-2015.2.9999.ebuild
parentapp-admin/glance: bup (diff)
downloadgentoo-0f49ad4562ee3ceae9f9e4d32aefcf5bd2953b29.tar.gz
gentoo-0f49ad4562ee3ceae9f9e4d32aefcf5bd2953b29.tar.bz2
gentoo-0f49ad4562ee3ceae9f9e4d32aefcf5bd2953b29.zip
sys-auth/keystone: bup
Package-Manager: portage-2.2.24
Diffstat (limited to 'sys-auth/keystone/keystone-2015.2.9999.ebuild')
-rw-r--r--sys-auth/keystone/keystone-2015.2.9999.ebuild63
1 files changed, 38 insertions, 25 deletions
diff --git a/sys-auth/keystone/keystone-2015.2.9999.ebuild b/sys-auth/keystone/keystone-2015.2.9999.ebuild
index cb547892b65..595da58fd3e 100644
--- a/sys-auth/keystone/keystone-2015.2.9999.ebuild
+++ b/sys-auth/keystone/keystone-2015.2.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 git-2 user
@@ -33,7 +33,7 @@ DEPEND="
)
mongo? (
>=dev-python/pymongo-2.6.3[${PYTHON_USEDEP}]
- <dev-python/pymongo-3.1[${PYTHON_USEDEP}]
+ <dev-python/pymongo-3.2[${PYTHON_USEDEP}]
)
ldap? (
>=dev-python/python-ldap-2.4[$(python_gen_usedep 'python2_7')]
@@ -41,7 +41,7 @@ DEPEND="
~dev-python/ldappool-1.0[$(python_gen_usedep 'python2_7')]
)
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- <=dev-python/coverage-4.0.2[${PYTHON_USEDEP}]
+ <=dev-python/coverage-4.0.3[${PYTHON_USEDEP}]
>=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
<=dev-python/fixtures-1.4.0-r9999[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
@@ -49,7 +49,7 @@ DEPEND="
>=dev-python/mock-1.2[${PYTHON_USEDEP}]
<=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- <=dev-python/oslotest-1.11.0[${PYTHON_USEDEP}]
+ <=dev-python/oslotest-2.0.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
<dev-python/sphinx-1.3[${PYTHON_USEDEP}]
@@ -62,11 +62,13 @@ DEPEND="
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
<=dev-python/testtools-1.8.1[${PYTHON_USEDEP}]
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-sphinx-3.3.1[${PYTHON_USEDEP}]
+ <=dev-python/oslo-sphinx-4.1.0[${PYTHON_USEDEP}]
>=dev-python/tempest-lib-0.8.0[${PYTHON_USEDEP}]
<=dev-python/tempest-lib-0.11.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.8.0[${PYTHON_USEDEP}]
<=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-0.1.1[${PYTHON_USEDEP}]
)"
RDEPEND="
${CDEPEND}
@@ -83,69 +85,80 @@ RDEPEND="
!~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
<=dev-python/routes-2.2[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
- <=dev-python/cryptography-1.1-r9999[${PYTHON_USEDEP}]
+ <=dev-python/cryptography-1.1.2-r9999[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
<=dev-python/six-1.10.0-r9999[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-0.9.9[sqlite,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
)
mysql? (
dev-python/mysql-python
>=dev-python/sqlalchemy-0.9.9[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
)
postgres? (
dev-python/psycopg:2
>=dev-python/sqlalchemy-0.9.9[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}]
<=dev-python/sqlalchemy-migrate-0.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
- <=dev-python/stevedore-1.9.0[${PYTHON_USEDEP}]
+ <=dev-python/stevedore-1.10.0[${PYTHON_USEDEP}]
>=dev-python/passlib-1.6[${PYTHON_USEDEP}]
<=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
- <=dev-python/python-keystoneclient-1.8.1-r9999[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-1.8.0[${PYTHON_USEDEP}]
+ <=dev-python/python-keystoneclient-2.0.0-r9999[${PYTHON_USEDEP}]
>=dev-python/keystonemiddleware-2.0.0[${PYTHON_USEDEP}]
- <=dev-python/keystonemiddleware-3.0.0-r9999[${PYTHON_USEDEP}]
+ !~dev-python/keystonemiddleware-2.4.0[${PYTHON_USEDEP}]
+ <=dev-python/keystonemiddleware-4.0.0-r9999[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-concurrency-2.8.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-concurrency-3.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-config-2.6.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-config-3.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-context-0.8.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-context-1.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-messaging-1.16.0[${PYTHON_USEDEP}]
!~dev-python/oslo-messaging-1.17.0[${PYTHON_USEDEP}]
!~dev-python/oslo-messaging-1.17.1[${PYTHON_USEDEP}]
- <=dev-python/oslo-messaging-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.6.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.6.1[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.7.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-2.9.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-3.1.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-messaging-3.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-2.4.1[${PYTHON_USEDEP}]
- <=dev-python/oslo-db-2.6.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-db-4.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-i18n-2.6.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-i18n-3.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-1.8.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-log-1.11.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-log-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-2.8.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-middleware-2.10.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-middleware-3.3.0[${PYTHON_USEDEP}]
>=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-policy-0.12.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-policy-1.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-serialization-1.11.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-serialization-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-service-0.7.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-service-0.12.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-service-1.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
- <=dev-python/oslo-utils-2.7.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-utils-2.6.0[${PYTHON_USEDEP}]
+ <=dev-python/oslo-utils-3.2.0[${PYTHON_USEDEP}]
>=dev-python/oauthlib-0.6.0[${PYTHON_USEDEP}]
<=dev-python/oauthlib-1.0.3[${PYTHON_USEDEP}]
>=dev-python/pysaml2-2.4.0[${PYTHON_USEDEP}]
- <=dev-python/pysaml2-3.0.2[${PYTHON_USEDEP}]
+ <=dev-python/pysaml2-4.0.0[${PYTHON_USEDEP}]
>=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
<=dev-python/dogpile-cache-0.5.7[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
!~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
~dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
+ <=dev-python/pycadf-2.0.1[${PYTHON_USEDEP}]
~dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]"
PATCHES=(