summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 10:16:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 10:18:35 -0500
commit31b02c259eefff2b08cd18c4b771f98512799e4c (patch)
tree17597ec3b92b6034427b9aaca383e6b288d11c85 /sys-auth/keystone/keystone-2015.2.9999.ebuild
parentsys-auth/keystone: still no py3 :( (diff)
downloadgentoo-31b02c259eefff2b08cd18c4b771f98512799e4c.tar.gz
gentoo-31b02c259eefff2b08cd18c4b771f98512799e4c.tar.bz2
gentoo-31b02c259eefff2b08cd18c4b771f98512799e4c.zip
sys-auth/keystone: readding mongo/memcached/ldap support
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-auth/keystone/keystone-2015.2.9999.ebuild')
-rw-r--r--sys-auth/keystone/keystone-2015.2.9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-auth/keystone/keystone-2015.2.9999.ebuild b/sys-auth/keystone/keystone-2015.2.9999.ebuild
index 595da58fd3e..881e4443f86 100644
--- a/sys-auth/keystone/keystone-2015.2.9999.ebuild
+++ b/sys-auth/keystone/keystone-2015.2.9999.ebuild
@@ -27,19 +27,6 @@ DEPEND="
${RDEPEND}
>=dev-python/bashate-0.2[${PYTHON_USEDEP}]
<=dev-python/bashate-0.3.2[${PYTHON_USEDEP}]
- memcached? (
- >=dev-python/python-memcached-1.48[${PYTHON_USEDEP}]
- <=dev-python/python-memcached-1.57[${PYTHON_USEDEP}]
- )
- mongo? (
- >=dev-python/pymongo-2.6.3[${PYTHON_USEDEP}]
- <dev-python/pymongo-3.2[${PYTHON_USEDEP}]
- )
- ldap? (
- >=dev-python/python-ldap-2.4[$(python_gen_usedep 'python2_7')]
- <=dev-python/python-ldap-2.4.20[$(python_gen_usedep 'python2_7')]
- ~dev-python/ldappool-1.0[$(python_gen_usedep 'python2_7')]
- )
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
<=dev-python/coverage-4.0.3[${PYTHON_USEDEP}]
>=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
@@ -159,7 +146,20 @@ RDEPEND="
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
~dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
<=dev-python/pycadf-2.0.1[${PYTHON_USEDEP}]
- ~dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]"
+ ~dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
+ memcached? (
+ >=dev-python/python-memcached-1.48[${PYTHON_USEDEP}]
+ <=dev-python/python-memcached-1.57[${PYTHON_USEDEP}]
+ )
+ mongo? (
+ >=dev-python/pymongo-2.6.3[${PYTHON_USEDEP}]
+ <dev-python/pymongo-3.2[${PYTHON_USEDEP}]
+ )
+ ldap? (
+ >=dev-python/python-ldap-2.4[$(python_gen_usedep 'python2_7')]
+ <=dev-python/python-ldap-2.4.20[$(python_gen_usedep 'python2_7')]
+ ~dev-python/ldappool-1.0[$(python_gen_usedep 'python2_7')]
+ )"
PATCHES=(
)