summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-05-15 21:50:51 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-05-15 21:52:45 -0700
commit8d2dcb41f4b7acbb1dac92107ee3c086221f06ae (patch)
tree7fc508738e7f6879fc6b655554d8ecef2761d7e2 /sys-auth/pam_mount/pam_mount-2.16-r1.ebuild
parentdev-util/lldb: arm64 stable wrt bug #685898 (diff)
downloadgentoo-8d2dcb41f4b7acbb1dac92107ee3c086221f06ae.tar.gz
gentoo-8d2dcb41f4b7acbb1dac92107ee3c086221f06ae.tar.bz2
gentoo-8d2dcb41f4b7acbb1dac92107ee3c086221f06ae.zip
sys-auth/pam_mount: fix LUKS2 header detection for AEAD/integrity
Trying to use a LUKS2 device via pam_mount fails with a cryptic message: 'No dmcrypt cipher specified (use -o cipher=xxx)' Trivial upstream patch is needed to fix the detection. See-Also: https://bbs.archlinux.org/viewtopic.php?id=242131 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-auth/pam_mount/pam_mount-2.16-r1.ebuild')
-rw-r--r--sys-auth/pam_mount/pam_mount-2.16-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild b/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild
new file mode 100644
index 000000000000..c13a0c5eacbb
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.16-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( dev-libs/openssl:0= )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+PATCHES=(
+ "${FILESDIR}"/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch
+)
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}