summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-13 20:52:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-13 22:24:16 +0100
commit717df9128fe9e558206be782cd23e4a27bddf0cf (patch)
tree19ef07e2b43a116b59b4ed563b0d3673aef2d0b4 /sys-auth/polkit-qt
parentmedia-gfx/luminance-hdr: Drop 2.5.1-r1 (diff)
downloadgentoo-717df9128fe9e558206be782cd23e4a27bddf0cf.tar.gz
gentoo-717df9128fe9e558206be782cd23e4a27bddf0cf.tar.bz2
gentoo-717df9128fe9e558206be782cd23e4a27bddf0cf.zip
sys-auth/polkit-qt: Use kde.org
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth/polkit-qt')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
index 65ed2776fbf3..1d09067472db 100644
--- a/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
+++ b/sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild
@@ -3,17 +3,20 @@
EAPI=7
-MY_PN="${PN}-1"
-MY_P="${MY_PN}-${PV}"
-inherit cmake-utils
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake-utils kde.org
DESCRIPTION="Qt wrapper around polkit-1 client libraries"
HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
-SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.xz"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${KDE_ORG_NAME}-${PV}"
+fi
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="debug"
RDEPEND="
@@ -28,8 +31,6 @@ DEPEND="${RDEPEND}"
DOCS=( AUTHORS README README.porting TODO )
-S="${WORKDIR}/${MY_P}"
-
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF