summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 19:45:18 +0200
committerMikle Kolyada <zlogene@gentoo.org>2019-08-13 00:44:12 +0300
commit7460b079440d446267c5b317fe5c81d72c631871 (patch)
tree4d7aa87ce149280557737be1f09534c732e36069 /sys-auth/sssd
parentsys-libs/glibc: port to EAPI=7 (diff)
downloadgentoo-7460b079440d446267c5b317fe5c81d72c631871.tar.gz
gentoo-7460b079440d446267c5b317fe5c81d72c631871.tar.bz2
gentoo-7460b079440d446267c5b317fe5c81d72c631871.zip
sys-auth/sssd: Disable broken Python support
Closes: https://bugs.gentoo.org/690510 Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth/sssd')
-rw-r--r--sys-auth/sssd/sssd-1.16.3-r2.ebuild14
-rw-r--r--sys-auth/sssd/sssd-2.1.0.ebuild14
-rw-r--r--sys-auth/sssd/sssd-2.2.0.ebuild14
3 files changed, 12 insertions, 30 deletions
diff --git a/sys-auth/sssd/sssd-1.16.3-r2.ebuild b/sys-auth/sssd/sssd-1.16.3-r2.ebuild
index 123d66457912..6397b5835b11 100644
--- a/sys-auth/sssd/sssd-1.16.3-r2.ebuild
+++ b/sys-auth/sssd/sssd-1.16.3-r2.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit autotools flag-o-matic linux-info multilib-minimal pam python-r1 systemd toolchain-funcs
+inherit autotools flag-o-matic linux-info multilib-minimal pam systemd toolchain-funcs
DESCRIPTION="System Security Services Daemon provides access to identity and authentication"
HOMEPAGE="https://pagure.io/SSSD/sssd"
@@ -14,7 +12,7 @@ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl autofs +locator +netlink nfsv4 nls +manpages python samba selinux sudo ssh test"
+IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
COMMON_DEP="
>=virtual/pam-0-r1[${MULTILIB_USEDEP}]
@@ -104,12 +102,6 @@ multilib_src_configure() {
# set initscript to sysv because the systemd option needs systemd to
# be installed. We provide our own systemd file anyway.
local myconf=()
- if [[ "${PYTHON_TARGETS}" == *python2* ]]; then
- myconf+=($(multilib_native_use_with python python2-bindings))
- fi
- if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
- myconf+=($(multilib_native_use_with python python3-bindings))
- fi
#Work around linker dependency problem.
append-ldflags "-Wl,--allow-shlib-undefined"
@@ -142,6 +134,8 @@ multilib_src_configure() {
$(multilib_native_use_with ssh)
--with-crypto="nss"
--with-initscript="sysv"
+ --without-python2-bindings
+ --without-python3-bindings
KRB5_CONFIG=/usr/bin/${CHOST}-krb5-config
)
diff --git a/sys-auth/sssd/sssd-2.1.0.ebuild b/sys-auth/sssd/sssd-2.1.0.ebuild
index 146e47c5995d..3bb83f60232e 100644
--- a/sys-auth/sssd/sssd-2.1.0.ebuild
+++ b/sys-auth/sssd/sssd-2.1.0.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit autotools flag-o-matic linux-info multilib-minimal pam python-r1 systemd toolchain-funcs
+inherit autotools flag-o-matic linux-info multilib-minimal pam systemd toolchain-funcs
DESCRIPTION="System Security Services Daemon provides access to identity and authentication"
HOMEPAGE="https://pagure.io/SSSD/sssd"
@@ -14,7 +12,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl autofs +locator +netlink nfsv4 nls +manpages python samba selinux sudo ssh test"
+IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
COMMON_DEP="
>=virtual/pam-0-r1[${MULTILIB_USEDEP}]
@@ -101,12 +99,6 @@ multilib_src_configure() {
# set initscript to sysv because the systemd option needs systemd to
# be installed. We provide our own systemd file anyway.
local myconf=()
- if [[ "${PYTHON_TARGETS}" == *python2* ]]; then
- myconf+=($(multilib_native_use_with python python2-bindings))
- fi
- if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
- myconf+=($(multilib_native_use_with python python3-bindings))
- fi
#Work around linker dependency problem.
append-ldflags "-Wl,--allow-shlib-undefined"
@@ -139,6 +131,8 @@ multilib_src_configure() {
$(multilib_native_use_with ssh)
--with-crypto="nss"
--with-initscript="sysv"
+ --without-python2-bindings
+ --without-python3-bindings
KRB5_CONFIG=/usr/bin/${CHOST}-krb5-config
)
diff --git a/sys-auth/sssd/sssd-2.2.0.ebuild b/sys-auth/sssd/sssd-2.2.0.ebuild
index 146e47c5995d..3bb83f60232e 100644
--- a/sys-auth/sssd/sssd-2.2.0.ebuild
+++ b/sys-auth/sssd/sssd-2.2.0.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit autotools flag-o-matic linux-info multilib-minimal pam python-r1 systemd toolchain-funcs
+inherit autotools flag-o-matic linux-info multilib-minimal pam systemd toolchain-funcs
DESCRIPTION="System Security Services Daemon provides access to identity and authentication"
HOMEPAGE="https://pagure.io/SSSD/sssd"
@@ -14,7 +12,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl autofs +locator +netlink nfsv4 nls +manpages python samba selinux sudo ssh test"
+IUSE="acl autofs +locator +netlink nfsv4 nls +manpages samba selinux sudo ssh test"
COMMON_DEP="
>=virtual/pam-0-r1[${MULTILIB_USEDEP}]
@@ -101,12 +99,6 @@ multilib_src_configure() {
# set initscript to sysv because the systemd option needs systemd to
# be installed. We provide our own systemd file anyway.
local myconf=()
- if [[ "${PYTHON_TARGETS}" == *python2* ]]; then
- myconf+=($(multilib_native_use_with python python2-bindings))
- fi
- if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
- myconf+=($(multilib_native_use_with python python3-bindings))
- fi
#Work around linker dependency problem.
append-ldflags "-Wl,--allow-shlib-undefined"
@@ -139,6 +131,8 @@ multilib_src_configure() {
$(multilib_native_use_with ssh)
--with-crypto="nss"
--with-initscript="sysv"
+ --without-python2-bindings
+ --without-python3-bindings
KRB5_CONFIG=/usr/bin/${CHOST}-krb5-config
)