summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-06-24 20:50:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-06-24 20:50:21 +0200
commit4ef9e0adc350f2d33575b668daf485785066da81 (patch)
tree89e9a58ae6fe04e106034b43e988f52f9ce65b85 /sys-auth
parentx11-base/xorg-server: 1.20.8-r1 added. (diff)
downloadgentoo-4ef9e0adc350f2d33575b668daf485785066da81.tar.gz
gentoo-4ef9e0adc350f2d33575b668daf485785066da81.tar.bz2
gentoo-4ef9e0adc350f2d33575b668daf485785066da81.zip
sys-auth/AusweisApp2: bump to version 1.20.1
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.20.1.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.1.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.1.ebuild
new file mode 100644
index 000000000000..869fe92ebae0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.20.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 6a730bf1ac79..0ddb211a7015 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.20.0.tar.gz 9727544 BLAKE2B 23d31b5cff2756948d563052ff53fffb737c6895fddada036969350b0a65f404f8def70f8ac4409a34fe9f83160e15cd8d4b6441f901f8e53e791ca386140383 SHA512 9222bc59521aa3533c79206df14b079e618f6efbdd04c11b4cc754027dc155d2ad4a321cabdbb35b9308f5e9631ca05e828969633125fe0ac651156669a784d0
+DIST AusweisApp2-1.20.1.tar.gz 10103225 BLAKE2B 79afb6e793827bec16c0ba4830d87e4ab5da35a76cb1ce1a9e59ee70a7e8c7606ae1f2244ac73fbe6ac758d559451dbaefe7cc4ad9f49adb33228af3d2647051 SHA512 08e51207bca38871b6cfc3146fa5252bd18bc018d91b7c4cb847519b0282aa5d0e6ff40ffa0bf389c421fed0d40855044e7eb9e0630ca8dc639c263d3055c1bf