summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-16 00:37:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-16 00:45:23 +0100
commit8d87d4e32d1b7e805752b76ee6ed86bfd5e8bace (patch)
tree8f4e343768b8339aaf82dead4f132eeb3b6acb36 /sys-auth
parentgames-engines/scummvm-tools: do not install into /usr/local (diff)
downloadgentoo-8d87d4e32d1b7e805752b76ee6ed86bfd5e8bace.tar.gz
gentoo-8d87d4e32d1b7e805752b76ee6ed86bfd5e8bace.tar.bz2
gentoo-8d87d4e32d1b7e805752b76ee6ed86bfd5e8bace.zip
sys-auth/elogind: 235.2 version bump
Closes: https://bugs.gentoo.org/644684 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/Manifest1
-rw-r--r--sys-auth/elogind/elogind-235.2.ebuild125
2 files changed, 126 insertions, 0 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
index 9466285a9383..b20a67b5a251 100644
--- a/sys-auth/elogind/Manifest
+++ b/sys-auth/elogind/Manifest
@@ -1,2 +1,3 @@
DIST elogind-234.4.tar.gz 973370 BLAKE2B 4fe00d2e22e3f94dfb6385fe61825be72ad2200f1368807ea816a971104cf384e3508ecf2877fa08394c6d0259874b2ceb7c4014f9e861dcd3b19c01bcd04602 SHA512 2df4fa318074d4f5e5dbba353cf817068a2703ffed40cdeae4cba2dea4ee143d1c5fc076b19419f1c4299392088c2c14b430d8aa1ded03b62117311802305d5e
DIST elogind-235.1.tar.gz 975726 BLAKE2B 2497be9bfc89e8d7eef1cc0a0880b5801940df282ba1c8e62031dcf888bcc107d071fe6d61f0e383a779829eafb060f421140d8c3c998937eec1c333ed7d0d13 SHA512 96442d073f4437c4432419cfaed3dc6f0323fc6967ae01b64ee07ae9a91d99084ba0066825a723a8a58ffff4c0a47150d64d40ff4dcc15a6250423dd5c358c38
+DIST elogind-235.2.tar.gz 975652 BLAKE2B c568b5eec89da14f55211cf4405d96b4bb1ea274d1237739a92c4f3585a6181a3e17dc7ed2af5161c649cae2149b3bd25f4212cf5a304383b254e39d7aa0b378 SHA512 6fa9194e8c21fa3d3caf6f9499f772dbfe38b9d40d8a0fe43ee32ad4b2acd672a78798d00694d1e0d6107625f4f3f06b71e0a5466ed4be446d670f9bcd961313
diff --git a/sys-auth/elogind/elogind-235.2.ebuild b/sys-auth/elogind/elogind-235.2.ebuild
new file mode 100644
index 000000000000..d6c31d67e037
--- /dev/null
+++ b/sys-auth/elogind/elogind-235.2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info meson pam udev xdg-utils
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+acl debug doc +pam +policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-235.1-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs cgroupmode rccgroupmode
+
+ rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ cgroupmode="legacy"
+
+ if [ "xhybrid" = "x${rccgroupmode}" ] ; then
+ cgroupmode="hybrid"
+ elif [ "xunified" = "x${rccgroupmode}" ] ; then
+ cgroupmode="unified"
+ fi
+
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dpamlibdir=$(getpam_mod_dir) \
+ -Dudevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ -Drootlibdir="${EPREFIX}"/$(get_libdir) \
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
+ -Drootprefix="${EPREFIX}/" \
+ -Dsmack=true \
+ -Dman=auto \
+ -Dhtml=$(usex doc auto false) \
+ -Dcgroup-controller=openrc \
+ -Ddefault-hierarchy=${cgroupmode} \
+ -Ddebug=$(usex debug elogind false) \
+ --buildtype $(usex debug debug release) \
+ -Dacl=$(usex acl true false) \
+ -Dpam=$(usex pam true false) \
+ -Dselinux=$(usex selinux true false)
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions" \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list boot | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from boot runlevel."
+ elif [ "$(rc-config list default | grep elogind)" != "" ]; then
+ ewarn "elogind is currently started from default runlevel."
+ ewarn "Please remove elogind from the default runlevel and"
+ ewarn "add it to the boot runlevel by:"
+ ewarn "# rc-update del elogind default"
+ ewarn "# rc-update add elogind boot"
+ else
+ ewarn "elogind is currently not started from any runlevel."
+ ewarn "You may add it to the boot runlevel by:"
+ ewarn "# rc-update add elogind boot"
+ fi
+ ewarn "Alternatively you can leave elogind out of any"
+ ewarn "runlevel. It will then be started automatically"
+ if use pam; then
+ ewarn "when the first service calls it via dbus, or the"
+ ewarn "first user logs into the system."
+ else
+ ewarn "when the first service calls it via dbus."
+ fi
+}