summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-03-30 23:46:20 +0800
committerIan Delaney <idella4@gentoo.org>2016-03-30 23:46:53 +0800
commit9801ab39cd246510f2bd167021d6f6517dfdce91 (patch)
tree385ee8dd52c9afbe58edbb659870b020ff3aa8bb /sys-auth
parentsys-auth/rtkit: add proxy user Marek Szuba and g-p-m to metadata.xml (diff)
downloadgentoo-9801ab39cd246510f2bd167021d6f6517dfdce91.tar.gz
gentoo-9801ab39cd246510f2bd167021d6f6517dfdce91.tar.bz2
gentoo-9801ab39cd246510f2bd167021d6f6517dfdce91.zip
sys-auth/rtkit: revbump to vn. 0.11-r2 required to effect all changes
inherits eclass linux-info, bump to EAPI 6, phase pkg_pretend added to offer to users kernel configuration options. Patch supplied by the proxy maintainer via Gentoo-bug #569546 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/rtkit/rtkit-0.11-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-auth/rtkit/rtkit-0.11-r2.ebuild b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
new file mode 100644
index 000000000000..baed267c8c7f
--- /dev/null
+++ b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils systemd user autotools linux-info
+
+DESCRIPTION="Realtime Policy and Watchdog Daemon"
+HOMEPAGE="http://0pointer.de/blog/projects/rtkit"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ sys-apps/dbus
+ sys-auth/polkit
+ sys-libs/libcap
+"
+DEPEND="${DEPEND}
+ app-arch/xz-utils
+"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~!RT_GROUP_SCHED"
+ ERROR_RT_GROUP_SCHED="CONFIG_RT_GROUP_SCHED is enabled. rtkit-daemon (or any other "
+ ERROR_RT_GROUP_SCHED+="real-time task) will not work unless run as root. Please consider "
+ ERROR_RT_GROUP_SCHED+="unsetting this option."
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ enewgroup rtkit
+ enewuser rtkit -1 -1 -1 "rtkit"
+}
+
+src_prepare() {
+ # Fedora patches
+ epatch "${FILESDIR}"/${P}-polkit.patch
+ epatch "${FILESDIR}"/${P}-gettime.patch
+ epatch "${FILESDIR}"/${P}-controlgroup.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(systemd_with_unitdir)
+}
+
+src_install() {
+ default
+
+ ./rtkit-daemon --introspect > org.freedesktop.RealtimeKit1.xml
+ insinto /usr/share/dbus-1/interfaces
+ doins org.freedesktop.RealtimeKit1.xml
+}