summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-09 23:57:55 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-09 23:58:13 +0200
commitb7466334251d3715c1a56da1bea3ff5e04fdcfed (patch)
treec2a321512ff078bf8efbf0a1ef28e5ccb24113b0 /sys-auth
parentdev-lang/php: amd64 stable wrt bug 556952 (diff)
downloadgentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.tar.gz
gentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.tar.bz2
gentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.zip
sys-auth/libfprint: Version bump (bug 553242).
Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libfprint/Manifest1
-rw-r--r--sys-auth/libfprint/libfprint-0.6.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/libfprint/Manifest b/sys-auth/libfprint/Manifest
index 597400411cb9..c90b34ebe3ca 100644
--- a/sys-auth/libfprint/Manifest
+++ b/sys-auth/libfprint/Manifest
@@ -2,3 +2,4 @@ DIST libfprint-0.4.0.tar.bz2 228518 SHA256 58f4056f498b8ba564a8ba2ee4a59cf2c3edb
DIST libfprint-0.5.0.tar.bz2 277118 SHA256 1d4d6832fe61e934a40cbe2b9fe9a92153ddccb5c874fce10f476f1113c1d76c SHA512 2a5a4d45bd11060964e34c70b2a41e45d220e3b97d07a962c939ec84988a85a4d97898c86b1e7f7c571d85bb7f4333231cf327f62907b40e6a1262cc5b365981 WHIRLPOOL a3c7763ab62d65e2bdf44e93a5230dcbde7065121427063c8b3bb19d597be1f1b5ae58e55e1e635b03eb004f1e08085585958b5ae0d85a5004dff939657190ad
DIST libfprint-0.5.1-add-vfs5011-driver.patch 338763 SHA256 329af64cc7273d46a56c603b8d242a51d3485655d475548ea47c66ef874946dd SHA512 446de6dea67c4b4d257f5427b5981f28ba6ab422dcd022862541e6216c1733f146f86ee5a8ad855c142ce1bc7795c72820112d68d68bb74bd68751a02dd42fb5 WHIRLPOOL d08b0011a0363497079c9a16b35e2eae64976c1a3b840e92560c55b399770e62ed4940278c729d24129e34503269876c8bd54d923b7656785ad1cda3ee6c0e1c
DIST libfprint-0.5.1.tar.bz2 277342 SHA256 0a2ea0e3bd4115bbe7261a0f43d5091ca32f9eaf8ca3364cca2b89c0f30c7962 SHA512 e1596e28f2730501b5957d2b4365f8eead7c0941434d064ceb6e5321d0e8495e71ab576b214881441bf1abc6ecba2b3ffafe5027f738f80c8c38b4e95866c8c7 WHIRLPOOL 444798713bf7603f7aa2bde104c9a62049566fa1e1e5bcf442d3f6212561dae41c69f579a6c5bc9a8df8efd09a60f12b8eb5b9909d1884413ea7e7caba637a37
+DIST libfprint-0.6.0.tar.bz2 323590 SHA256 4e1787da3367d18d931f189a7fd9c92f6dc01f799d0c03ed4595603c1eceaf5c SHA512 2ab9ceec0c357779c94d3b8e94c11a733825bd735bec0e5c762d215d69bf295da0c5db7fd365e2a7efdcf25747777371f793b5e99d5c98e1bf9dcb1170e10ef9 WHIRLPOOL ecd0d3402cd24245f790a34d796a964f6c211096e906299fdce49d5a2eed0f73717e079749c877680e3000d9b4dd11d534759efb313a133e40e950a1a0c62a03
diff --git a/sys-auth/libfprint/libfprint-0.6.0.ebuild b/sys-auth/libfprint/libfprint-0.6.0.ebuild
new file mode 100644
index 000000000000..0c947ac17070
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils udev vcs-snapshot
+
+MY_PV="V_${PV//./_}"
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/libusb:1
+ dev-libs/glib:2
+ dev-libs/nss"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # upeke2 and fdu2000 were missing from all_drivers.
+ sed -e '/^all_drivers=/s:"$: upeke2 fdu2000":' \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-drivers=all \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) \
+ -enable-udev-rules \
+ --with-udev-rules-dir=$(get_udevdir)/rules.d
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
+}