summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-04-22 15:24:21 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-04-22 15:26:21 +0300
commitcd27db05936853b3a8f0fd4560f564eef9c18daa (patch)
treeb6dd6d670c7b69a913bfaf4872a4b53de4f940fb /sys-auth
parentapp-admin/ps_mem: new snapshot for a few upstream fixes (diff)
downloadgentoo-cd27db05936853b3a8f0fd4560f564eef9c18daa.tar.gz
gentoo-cd27db05936853b3a8f0fd4560f564eef9c18daa.tar.bz2
gentoo-cd27db05936853b3a8f0fd4560f564eef9c18daa.zip
sys-auth/pam_ssh: fix build with gcc-10
Closes: https://bugs.gentoo.org/709312 Thanks-to: Jeroen Roovers <jer@gentoo.org> Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch11
-rw-r--r--sys-auth/pam_ssh/pam_ssh-2.3.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch b/sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch
new file mode 100644
index 000000000000..9871b4297c7b
--- /dev/null
+++ b/sys-auth/pam_ssh/files/pam_ssh-gcc10-fix.patch
@@ -0,0 +1,11 @@
+--- a/ge25519.h
++++ b/ge25519.h
+@@ -28,7 +28,7 @@
+ fe25519 t;
+ } ge25519;
+
+-const ge25519 ge25519_base;
++extern const ge25519 ge25519_base;
+
+ int ge25519_unpackneg_vartime(ge25519 *r, const unsigned char p[32]);
+
diff --git a/sys-auth/pam_ssh/pam_ssh-2.3.ebuild b/sys-auth/pam_ssh/pam_ssh-2.3.ebuild
index aa31b08e2c85..23e4dd080959 100644
--- a/sys-auth/pam_ssh/pam_ssh-2.3.ebuild
+++ b/sys-auth/pam_ssh/pam_ssh-2.3.ebuild
@@ -12,17 +12,18 @@ SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.xz"
LICENSE="BSD-2 BSD ISC"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
# Only supports OpenSSH via `ssh-agent` #282993
DEPEND="sys-libs/pam
dev-libs/openssl:0="
+
RDEPEND="${DEPEND}
net-misc/openssh"
PATCHES=(
# 503424#c5
"${FILESDIR}"/${PN}-2.1-dot-ssh-check.patch
+ "${FILESDIR}"/${PN}-gcc10-fix.patch
)
src_configure() {