summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-03-19 14:38:48 -0400
committerCraig Andrews <candrews@gentoo.org>2019-03-20 11:29:32 -0400
commitf8b26eb06c84b49e3aa40a0f37921ae779c7cbf8 (patch)
treeb824800bf3e4febaeb0ddfdf365994bbe0aea188 /sys-block/zram-init/zram-init-8.1.ebuild
parentmedia-sound/kid3: Bump to version 3.7.1 (diff)
downloadgentoo-f8b26eb06c84b49e3aa40a0f37921ae779c7cbf8.tar.gz
gentoo-f8b26eb06c84b49e3aa40a0f37921ae779c7cbf8.tar.bz2
gentoo-f8b26eb06c84b49e3aa40a0f37921ae779c7cbf8.zip
sys-block/zram-init: 8.1 version bump, EAPI=7
Closes: https://bugs.gentoo.org/663898 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'sys-block/zram-init/zram-init-8.1.ebuild')
-rw-r--r--sys-block/zram-init/zram-init-8.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-block/zram-init/zram-init-8.1.ebuild b/sys-block/zram-init/zram-init-8.1.ebuild
new file mode 100644
index 000000000000..2b9aa4db74d0
--- /dev/null
+++ b/sys-block/zram-init/zram-init-8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+RDEPEND=">=app-shells/push-2.0
+ !<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ default
+}
+
+src_install() {
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc AUTHORS ChangeLog README.md
+ readme.gentoo_create_doc
+ into /
+ dosbin sbin/*
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}