summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-18 22:56:50 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-18 22:57:36 +0000
commitd51bc115e6b563452e43cc6f49a83a72a2e6f615 (patch)
treececb1b8551d4a2e915a57bcc44c51655777f4c86 /sys-block
parentsci-astronomy/stellarium: Drop 0.19.0, 0.19.1, 0.19.2 (diff)
downloadgentoo-d51bc115e6b563452e43cc6f49a83a72a2e6f615.tar.gz
gentoo-d51bc115e6b563452e43cc6f49a83a72a2e6f615.tar.bz2
gentoo-d51bc115e6b563452e43cc6f49a83a72a2e6f615.zip
sys-block/seekwatcher: bump up to 0.13
Add python-3 support. Reported-by: Michał Górny Closes: https://bugs.gentoo.org/705654 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/seekwatcher/Manifest1
-rw-r--r--sys-block/seekwatcher/seekwatcher-0.13.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-block/seekwatcher/Manifest b/sys-block/seekwatcher/Manifest
index 9eff05953215..7ae8b6bc75f1 100644
--- a/sys-block/seekwatcher/Manifest
+++ b/sys-block/seekwatcher/Manifest
@@ -1 +1,2 @@
DIST seekwatcher-0.12_p20091015.tar.gz 105328 BLAKE2B 6ce83dc7655ad9b070b09c745ebff881e30f352955264c3cf18902293466896a2b8ca1454d00848777aa46e1026d9c44cdf2979c0a8cc1758d794efc3f5f8fb7 SHA512 fc35399900fac83bf2921a137059f1af23e65a778aad105a9cbb8bb869328723f7e2b3bb19b28e7eed04eca65a39cb637ba5932ee4f5f3a882a7b52715a9aded
+DIST seekwatcher-0.13.tar.gz 25811 BLAKE2B 72c574e239a346620eb5a1c574365f18dc745e926bfb4f191dd9997ff73b26e716ded9679481be34149c3e5e424077a23a264e7dabe9423eafb396f687085dbd SHA512 687c1190a4d62ee4d7237c6930358d69d2045a7fd5af19caf9fdde8dfae8fcc64ba2d382445af2b038bc31f77c356f31b8dbff2d52cdaf4320881d1b1340dd17
diff --git a/sys-block/seekwatcher/seekwatcher-0.13.ebuild b/sys-block/seekwatcher/seekwatcher-0.13.ebuild
new file mode 100644
index 000000000000..8b69e1eacdb8
--- /dev/null
+++ b/sys-block/seekwatcher/seekwatcher-0.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="generates graphs from blktrace to help visualize IO patterns and performance"
+HOMEPAGE="https://github.com/trofi/seekwatcher"
+SRC_URI="https://github.com/trofi/seekwatcher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/cython"
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sys-block/blktrace
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"