summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-04-21 20:09:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-04-21 20:10:09 +0100
commitb1cc70ce5c810fb85684ea8f681465a20546c0c8 (patch)
treed7818b5d3f6e595c326a540ceb98a587fb76a48f /sys-boot/elilo/elilo-3.16-r2.ebuild
parentmedia-gfx/imagemagick: Bump (diff)
downloadgentoo-b1cc70ce5c810fb85684ea8f681465a20546c0c8.tar.gz
gentoo-b1cc70ce5c810fb85684ea8f681465a20546c0c8.tar.bz2
gentoo-b1cc70ce5c810fb85684ea8f681465a20546c0c8.zip
sys-boot/elilo: fix build failure on ia64 against gnu-efi-3.0.6
Disambiguate setpjmp()/longjmp()/jmp_buf implementation across elilo copy and gnu-efi-3.0.6. To avoid behaviour change I'm keeping elilo's implementation for now as the jmp_buf passing ABI is slightly different across the two. ``` setjmp.h:25:14: error: conflicting types for 'jmp_buf' typedef long jmp_buf[_JBLEN] __attribute__ ((aligned (16))); ^~~~~~~ In file included from /usr/include/efi/efisetjmp.h:5:0, from /usr/include/efi/efi.h:60, from gzip.c:29: /usr/include/efi/ia64/efisetjmp_arch.h:45:23: note: previous declaration of 'jmp_buf' was here } ALIGN(JMPBUF_ALIGN) jmp_buf; ^~~~~~~ ``` Reported-by: Stanton Arch Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-boot/elilo/elilo-3.16-r2.ebuild')
-rw-r--r--sys-boot/elilo/elilo-3.16-r2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/sys-boot/elilo/elilo-3.16-r2.ebuild b/sys-boot/elilo/elilo-3.16-r2.ebuild
new file mode 100644
index 000000000000..840e7f568f8e
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.16-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="https://sourceforge.net/projects/elilo/"
+SRC_URI="mirror://sourceforge/elilo/${P}-all.tar.gz
+ mirror://debian/pool/main/e/elilo/elilo_3.14-3.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0g
+ dev-util/patchutils"
+# dosfstools[compat] to enable 'dosfsck' symlink
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools[compat]"
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.16-elilo-loop.patch #299665
+ "${FILESDIR}"/${PN}-3.16-gnu-efi-3.0.6-ia64.patch
+)
+
+src_unpack() {
+ unpack ${A} ./${P}-source.tar.gz
+ mv debian "${S}"/ || die
+}
+
+src_prepare() {
+ default
+
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # Now Gentooize it.
+ sed -i \
+ -e '1s:/bin/sh:/bin/bash:' \
+ -e "s:##VERSION##:${PV}:" \
+ -e 's:Debian GNU/:Gentoo :g' \
+ -e 's:Debian:Gentoo:g' \
+ -e 's:debian:gentoo:g' \
+ -e "s:dpkg --print-architecture:echo ${iarch}:" \
+ debian/elilo.sh || die
+}
+
+src_compile() {
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ local libdir="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ emake -j1 \
+ prefix= \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ HOSTARCH=${iarch} \
+ ARCH=${iarch} \
+ EFIINC="${SYSROOT}${EPREFIX}/usr/include/efi" \
+ GNUEFILIB="${libdir}" \
+ EFILIB="${libdir}" \
+ EFICRT0="${libdir}"
+}
+
+src_install() {
+ exeinto /usr/lib/elilo
+ doexe elilo.efi
+
+ newsbin debian/elilo.sh elilo
+ dosbin tools/eliloalt
+
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ doman debian/*.[0-9]
+}