summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-10-02 11:41:11 -0400
committerMike Gilbert <floppym@gentoo.org>2018-10-02 11:41:11 -0400
commit1a94fdfff13237475b08c75461ea5b2c55a8796d (patch)
tree49455c25d2029dc8534aa560920e7fc625af19e2 /sys-boot
parentsys-apps/bolt: 0.5 add missing glib-utils dep (diff)
downloadgentoo-1a94fdfff13237475b08c75461ea5b2c55a8796d.tar.gz
gentoo-1a94fdfff13237475b08c75461ea5b2c55a8796d.tar.bz2
gentoo-1a94fdfff13237475b08c75461ea5b2c55a8796d.zip
sys-boot/systemd-boot: rename debug meson option
Closes: https://bugs.gentoo.org/667582 Package-Manager: Portage-2.3.50_p10, Repoman-2.3.11_p17 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/systemd-boot/files/239-debug-extra.patch40
-rw-r--r--sys-boot/systemd-boot/systemd-boot-239.ebuild3
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-boot/systemd-boot/files/239-debug-extra.patch b/sys-boot/systemd-boot/files/239-debug-extra.patch
new file mode 100644
index 000000000000..19db590257cf
--- /dev/null
+++ b/sys-boot/systemd-boot/files/239-debug-extra.patch
@@ -0,0 +1,40 @@
+From 8f6b442a78d0b485f044742ad90b2e8271b4e68e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Sun, 19 Aug 2018 19:11:30 +0200
+Subject: [PATCH] meson: rename -Ddebug to -Ddebug-extra
+
+Meson added -Doptimization and -Ddebug options, which obviously causes
+a conflict with our -Ddebug options. Let's rename it.
+
+Fixes #9883.
+---
+ meson.build | 2 +-
+ meson_options.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index f79ac4b12e7..2209c935ad6 100644
+--- a/meson.build
++++ b/meson.build
+@@ -763,7 +763,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
+
+ enable_debug_hashmap = false
+ enable_debug_mmap_cache = false
+-foreach name : get_option('debug')
++foreach name : get_option('debug-extra')
+ if name == 'hashmap'
+ enable_debug_hashmap = true
+ elif name == 'mmap-cache'
+diff --git a/meson_options.txt b/meson_options.txt
+index e3140c8c110..7b1f61bf464 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -45,7 +45,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
+ description : 'path to debug shell binary')
+ option('debug-tty', type : 'string', value : '/dev/tty9',
+ description : 'specify the tty device for debug shell')
+-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
++option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
+ description : 'enable extra debugging')
+ option('memory-accounting-default', type : 'boolean',
+ description : 'enable MemoryAccounting= by default')
diff --git a/sys-boot/systemd-boot/systemd-boot-239.ebuild b/sys-boot/systemd-boot/systemd-boot-239.ebuild
index 48d61ac38b29..4eb8570b73cc 100644
--- a/sys-boot/systemd-boot/systemd-boot-239.ebuild
+++ b/sys-boot/systemd-boot/systemd-boot-239.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,6 +37,7 @@ S="${WORKDIR}/systemd-${PV}"
PATCHES=(
"${FILESDIR}/237-libshared-static.patch"
+ "${FILESDIR}/239-debug-extra.patch"
)
src_configure() {