summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:20:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:21:31 -0500
commit97bedd6527cf2305109a9063dc664d7f008f7d18 (patch)
treed45b08c05a3845aefb737e9acd093f2441143beb /sys-cluster
parentsys-cluster/heat: 14.0.0 ussuri bump (diff)
downloadgentoo-97bedd6527cf2305109a9063dc664d7f008f7d18.tar.gz
gentoo-97bedd6527cf2305109a9063dc664d7f008f7d18.tar.bz2
gentoo-97bedd6527cf2305109a9063dc664d7f008f7d18.zip
sys-cluster/openstack-meta: USSURI bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2020.1.0.ebuild34
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild27
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-cluster/openstack-meta/openstack-meta-2020.1.0.ebuild b/sys-cluster/openstack-meta/openstack-meta-2020.1.0.ebuild
new file mode 100644
index 000000000000..e39f81afaaaa
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2020.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( >=sys-auth/keystone-17.0.0
+ <sys-auth/keystone-18 )
+ swift? ( ~sys-cluster/swift-2.25.0 )
+ neutron? ( >=sys-cluster/neutron-16.0.0
+ <sys-cluster/neutron-17 )
+ glance? ( >=app-admin/glance-20.0.0
+ <app-admin/glance-21 )
+ cinder? ( >=sys-cluster/cinder-16.0.0
+ <sys-cluster/cinder-17 )
+ nova? ( >=sys-cluster/nova-21.0.0
+ <sys-cluster/nova-22 )
+ heat? ( >=sys-cluster/heat-14.0.0
+ <sys-cluster/heat-15 )
+ placement? ( >=sys-cluster/placement-3.0.0
+ <sys-cluster/placement-4 )
+"
diff --git a/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild
new file mode 100644
index 000000000000..d214cba5b919
--- /dev/null
+++ b/sys-cluster/openstack-meta/openstack-meta-2020.1.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
+HOMEPAGE="https://openstack.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="cinder glance heat keystone neutron nova placement swift"
+
+if [[ ${PV} != *9999 ]];then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND=""
+RDEPEND="
+ keystone? ( ~sys-auth/keystone-${PV} )
+ swift? ( ~sys-cluster/swift-${PV} )
+ neutron? ( ~sys-cluster/neutron-${PV} )
+ glance? ( ~app-admin/glance-${PV} )
+ cinder? ( ~sys-cluster/cinder-${PV} )
+ nova? ( ~sys-cluster/nova-${PV} )
+ heat? ( ~sys-cluster/heat-${PV} )
+ placement? ( ~sys-cluster/placement-${PV} )
+"