summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-03-23 15:23:23 +0100
committerFabian Groffen <grobian@gentoo.org>2017-03-23 15:23:23 +0100
commitad2f301de2a6b184295c645c1142c3bdf10112a3 (patch)
tree77007d3eeeae1bc8318647c171227e3d62981655 /sys-devel/autoconf
parentmedia-sound/gnome-music: Drop dead implementation from PYTHON_COMPAT again (diff)
downloadgentoo-ad2f301de2a6b184295c645c1142c3bdf10112a3.tar.gz
gentoo-ad2f301de2a6b184295c645c1142c3bdf10112a3.tar.bz2
gentoo-ad2f301de2a6b184295c645c1142c3bdf10112a3.zip
sys-devel/autoconf: add Prefix keywords and Darwin patch
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/autoconf-2.13.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r2.ebuild13
-rw-r--r--sys-devel/autoconf/files/autoconf-2.61-darwin.patch11
3 files changed, 23 insertions, 5 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13.ebuild b/sys-devel/autoconf/autoconf-2.13.ebuild
index 60f3ef570bb6..7cc31570e931 100644
--- a/sys-devel/autoconf/autoconf-2.13.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="${PV:0:3}"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="userland_BSD"
DEPEND=">=sys-apps/texinfo-4.3
diff --git a/sys-devel/autoconf/autoconf-2.69-r2.ebuild b/sys-devel/autoconf/autoconf-2.69-r2.ebuild
index 593e8a0454d5..fd7f617cb4a2 100644
--- a/sys-devel/autoconf/autoconf-2.69-r2.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
@@ -12,7 +14,7 @@ if [[ ${PV} == "9999" ]] ; then
else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="Used to create autoconfiguration files"
@@ -33,6 +35,11 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
if [[ -z ${__EBLITS__} && -n ${FILESDIR} ]] ; then
source "${FILESDIR}"/eblits/main.eblit || die
fi
-src_prepare() { eblit-run src_prepare ; }
+src_prepare() {
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ [[ ${CHOST} == *-darwin* ]] && \
+ PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ eblit-run src_prepare
+}
src_configure() { eblit-run src_configure ; }
src_install() { eblit-run src_install ; }
diff --git a/sys-devel/autoconf/files/autoconf-2.61-darwin.patch b/sys-devel/autoconf/files/autoconf-2.61-darwin.patch
new file mode 100644
index 000000000000..2ac2be361db1
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.61-darwin.patch
@@ -0,0 +1,11 @@
+--- bin/autoreconf.in
++++ bin/autoreconf.in
+@@ -110,7 +110,7 @@
+ my $autoheader = $ENV{'AUTOHEADER'} || '@bindir@/@autoheader-name@';
+ my $automake = $ENV{'AUTOMAKE'} || 'automake';
+ my $aclocal = $ENV{'ACLOCAL'} || 'aclocal';
+-my $libtoolize = $ENV{'LIBTOOLIZE'} || 'libtoolize';
++my $libtoolize = $ENV{'LIBTOOLIZE'} || 'glibtoolize';
+ my $autopoint = $ENV{'AUTOPOINT'} || 'autopoint';
+
+ # --install -- as --add-missing in other tools.