summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-04 20:06:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-04 20:08:33 +0100
commitfbd35d9e019d96c6ef2296090bb80fa72ea02775 (patch)
treeb19010e7bd08e454bf2db64369f71a70750795f1 /sys-devel/autoconf
parentapp-misc/graphlcd-base: use patch from upstream (diff)
downloadgentoo-fbd35d9e019d96c6ef2296090bb80fa72ea02775.tar.gz
gentoo-fbd35d9e019d96c6ef2296090bb80fa72ea02775.tar.bz2
gentoo-fbd35d9e019d96c6ef2296090bb80fa72ea02775.zip
sys-devel/autoconf: 2.70 revbump to add various upstream fixes
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/Manifest1
-rw-r--r--sys-devel/autoconf/autoconf-2.70-r2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index 0cdbace1c304..0a40af81ae80 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -2,4 +2,5 @@ DIST autoconf-2.13.tar.gz 443844 BLAKE2B ade10f9d4a0b1a0e8b752eee817cfe100d77b07
DIST autoconf-2.64.tar.xz 1113892 BLAKE2B 598873209a67725150cd4cf09c4b78b26b3d1782f259846da48dc8106a1d32ae2b24f3a864c3be0e9e8dc7d6b6ca8781b83ff33a691c88e68391d1ea861ccf23 SHA512 ee4b504447c14a59b849d0915e55a90522cfb071d1583af2bd3575e5a05d7bd290e55e0e9d0760c8f36043f926199fc2d962b559d27d2f95c70d0e147b4ad0a3
DIST autoconf-2.69-runstatedir_patches.tar.xz 257096 BLAKE2B ae765e0ca7fe8261117f6f6b75611c232fc3d4016c22c86346afa72f2b7e6c3b7ccc1f9dfe134b2443f8bde6d578b503d79cf88472f76ce75b6c2e843ef55b8e SHA512 55f93299fe5243151f6bb782986a7935270f06d5065929f4d365a37aba05703e3ce66ecf7981d30413db50ee6b4f77d81d10a71b539c8a366c5c5a156c5443da
DIST autoconf-2.69.tar.xz 1214744 BLAKE2B 71d33d72a06e9a05fbed0eda73bc9d8a3805c7c90bf082959862f93f3c5f01192114176e84d84ecb58fa99512eafbc0ab21ad1407be18c8c63bb3dc1117c482d SHA512 995d3e5a8eb1eb37e2b7fae53c6ec7a9b4df997286b7d643344818f94636756b1bf5ff5ea9155e755cb9461149a853dfbf2886fc6bd7132e5afa9c168e306e9b
+DIST autoconf-2.70-patches-01.tar.xz 27284 BLAKE2B fa4ef923d487f600de98d765d3db23c73cd546f777c19986f9179cbe0e9eb254e3bb4c8107b6ce9f2c1f008b4c72033565711f0d8b63e6538b83ec56a2d75875 SHA512 648604ec24decbc48d281049eca94e7e7146d013c006297d9d9c71b749bd856684b8ab8550ac8961ce506b036ad25b7236dfb5e53114c10edfefbd58ecc55020
DIST autoconf-2.70.tar.xz 1346528 BLAKE2B 7a14f966f1fb89a250aedb03d483ab1f92d73a7085bc289094b62984620563922d041e717274270af0afaf52f058b4c6402c1af14cce58d70d5d884414797c80 SHA512 af4af6b8811baa424c00990b368a6cbfb1d598dde9ee08dce2a5fc32cb9517e6e683a59d6852507f6a72d499fc298c4171b6f06962cf3ba40cf1557cfb6069fe
diff --git a/sys-devel/autoconf/autoconf-2.70-r2.ebuild b/sys-devel/autoconf/autoconf-2.70-r2.ebuild
new file mode 100644
index 000000000000..78c0373eb06a
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.70-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/autoconf.git"
+ inherit git-r3
+else
+ # For _beta handling replace with real version number
+ MY_PV="${PV}"
+ MY_P="${PN}-${MY_PV}"
+ PATCH_TARBALL_NAME="${PN}-2.70-patches-01"
+ SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz -> ${P}.tar.xz
+ https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz -> ${P}.tar.xz"
+ SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PATCH_TARBALL_NAME}.tar.xz"
+ [[ "${PV}" == *_beta* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit toolchain-autoconf
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3"
+SLOT="${PV/_*}"
+IUSE="emacs"
+
+BDEPEND=">=sys-devel/m4-1.4.16
+ >=dev-lang/perl-5.6"
+RDEPEND="${BDEPEND}
+ >=sys-devel/autoconf-wrapper-14
+ sys-devel/gnuconfig
+ !~sys-devel/${P}:2.5"
+[[ ${PV} == "9999" ]] && BDEPEND+=" >=sys-apps/texinfo-4.3"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_prepare() {
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ fi
+
+ # Save timestamp to avoid later makeinfo call
+ touch -r doc/{,old_}autoconf.texi || die
+
+ local pdir
+ for pdir in "${WORKDIR}"/{upstream_,}patches ; do
+ if [[ -d "${pdir}" ]] ; then
+ eapply ${pdir}
+ fi
+ done
+
+ toolchain-autoconf_src_prepare
+
+ # Restore timestamp to avoid makeinfo call
+ # We already have an up to date autoconf.info page at this point.
+ touch -r doc/{old_,}autoconf.texi || die
+}
+
+src_install() {
+ default
+
+ local f
+ for f in config.{guess,sub} ; do
+ ln -fs ../../gnuconfig/${f} \
+ "${ED}"/usr/share/autoconf-*/build-aux/${f} || die
+ done
+}