summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-29 16:38:09 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-29 16:38:18 +0200
commitfef54b9ccadd995fa3af6c1446ebc9aa678075f4 (patch)
treea670d4ab53d00b7d50713ad77362e7cc6b2126ff /sys-devel/autoconf
parentapp-editors/jasspa-microemacs: Fix compilation with glibc-2.32. (diff)
downloadgentoo-fef54b9ccadd995fa3af6c1446ebc9aa678075f4.tar.gz
gentoo-fef54b9ccadd995fa3af6c1446ebc9aa678075f4.tar.bz2
gentoo-fef54b9ccadd995fa3af6c1446ebc9aa678075f4.zip
sys-devel/autoconf: make tests compatible with bash-5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r5.ebuild1
-rw-r--r--sys-devel/autoconf/files/autoconf-2.69-make-tests-bash5-compatible.patch63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-devel/autoconf/autoconf-2.69-r5.ebuild b/sys-devel/autoconf/autoconf-2.69-r5.ebuild
index 914d3c007fae..a1b71fdccd3f 100644
--- a/sys-devel/autoconf/autoconf-2.69-r5.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r5.ebuild
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.69-perl-5.26.patch
"${FILESDIR}"/${P}-fix-libtool-test.patch
"${FILESDIR}"/${PN}-2.69-perl-5.26-2.patch
+ "${FILESDIR}"/${P}-make-tests-bash5-compatible.patch
"${WORKDIR}"/patches/${P}-runstatedir.patch
"${WORKDIR}"/patches/${P}-texinfo.patch
diff --git a/sys-devel/autoconf/files/autoconf-2.69-make-tests-bash5-compatible.patch b/sys-devel/autoconf/files/autoconf-2.69-make-tests-bash5-compatible.patch
new file mode 100644
index 000000000000..1afcec15bb4f
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.69-make-tests-bash5-compatible.patch
@@ -0,0 +1,63 @@
+From 5b9db67786a428164abafe626ab11a2754aad528 Mon Sep 17 00:00:00 2001
+From: Ondrej Dubaj <odubaj@redhat.com>
+Date: Wed, 28 Aug 2019 07:39:50 +0200
+Subject: Port tests to Bash 5
+
+* tests/local.at (AT_CHECK_ENV, AT_CONFIG_CMP):
+Add BASH_ARGC, BASH_ARGV to list of variables to be ignored when
+comparing variable space dumps.
+(AT_CONFIG_CMP): Also ignore LINENO.
+* tests/m4sh.at: Also unset LINENO in 'reference' and 'test/test-1'.
+---
+ tests/local.at | 5 ++++-
+ tests/m4sh.at | 4 ++--
+ 2 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/tests/local.at b/tests/local.at
+index a22958c0..852be285 100644
+--- a/tests/local.at
++++ b/tests/local.at
+@@ -325,7 +325,7 @@ if test -f state-env.before && test -f state-env.after; then
+ [AWK|LEX|LEXLIB|LEX_OUTPUT_ROOT|LN_S|M4|MKDIR_P|RANLIB|SET_MAKE|YACC],
+ [GREP|[EF]GREP|SED],
+ [[_@]|.[*#?$].],
+- [argv|ARGC|LINENO|OLDPWD|PIPESTATUS|RANDOM|SECONDS]))=' \
++ [argv|ARGC|LINENO|BASH_ARGC|BASH_ARGV|OLDPWD|PIPESTATUS|RANDOM|SECONDS]))=' \
+ $act_file ||
+ test $? -eq 1 || echo failed >&2
+ ) 2>stderr-$act_file |
+@@ -382,6 +382,9 @@ do
+ /'\'\\\$\''=/ d
+ /^argv=/ d
+ /^ARGC=/ d
++ /^BASH_ARGC=/ d
++ /^BASH_ARGV=/ d
++ /^LINENO=/ d
+ ' $act_file >at_config_vars-$act_file
+ done
+ AT_CMP([at_config_vars-$1], [at_config_vars-$2])[]dnl
+diff --git a/tests/m4sh.at b/tests/m4sh.at
+index e9d70b02..cbdfcb62 100644
+--- a/tests/m4sh.at
++++ b/tests/m4sh.at
+@@ -254,7 +254,7 @@ AT_CHECK([autom4te -l m4sh $1.as -o $1])
+ # `_oline_', once processed and ran, produces our reference.
+ # We check that we find ourselves by looking at a string which is
+ # available only in the original script: `_oline_'.
+-AT_DATA_LINENO([reference], [false], [__OLINE__], [_oline__])
++AT_DATA_LINENO([reference], [true], [__OLINE__], [_oline__])
+ AT_CHECK([./reference], 0, [stdout])
+
+ # The reference:
+@@ -264,7 +264,7 @@ mv stdout expout
+ # Be sure to be out of the PATH.
+ AT_CHECK([mkdir test || exit 77])
+
+-AT_DATA_LINENO([test/test-1], [false], [__LINENO__], [LINENO])
++AT_DATA_LINENO([test/test-1], [true], [__LINENO__], [LINENO])
+ AT_CHECK([./test/test-1], 0, [expout])
+ AT_CHECK([(PATH=test$PATH_SEPARATOR$PATH; export PATH; exec test-1)],
+ 0, [expout])
+--
+cgit v1.2.1
+