summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-04 15:50:48 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-04 15:51:42 +0100
commit2b5e4127a29101caf452f81263532016764a264f (patch)
tree8017978aa4cdbe506a80a95207621b6def2b9e96 /sys-devel/autogen
parentdev-php/pecl-imagick: Add PHP 7.2 support (diff)
downloadgentoo-2b5e4127a29101caf452f81263532016764a264f.tar.gz
gentoo-2b5e4127a29101caf452f81263532016764a264f.tar.bz2
gentoo-2b5e4127a29101caf452f81263532016764a264f.zip
sys-devel/autogen: Fixed build with =dev-scheme/guile-2.2*
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/autogen-5.18.12.ebuild10
-rw-r--r--sys-devel/autogen/files/autogen-guile-2.2.patch34
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-devel/autogen/autogen-5.18.12.ebuild b/sys-devel/autogen/autogen-5.18.12.ebuild
index 9d29603d3e72..65274d31baa6 100644
--- a/sys-devel/autogen/autogen-5.18.12.ebuild
+++ b/sys-devel/autogen/autogen-5.18.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit ltprune toolchain-funcs
DESCRIPTION="Program and text file generation"
HOMEPAGE="https://www.gnu.org/software/autogen/"
@@ -20,7 +20,13 @@ RDEPEND=">=dev-scheme/guile-2.0:=
dev-libs/libxml2"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-guile-2.2.patch"
+)
+
src_prepare() {
+ default
+
# https://savannah.gnu.org/support/index.php?109050
sed -i \
-e "/--cflags-only-I/s:pkg-config:$(tc-getPKG_CONFIG):" \
diff --git a/sys-devel/autogen/files/autogen-guile-2.2.patch b/sys-devel/autogen/files/autogen-guile-2.2.patch
new file mode 100644
index 000000000000..8ef904adb029
--- /dev/null
+++ b/sys-devel/autogen/files/autogen-guile-2.2.patch
@@ -0,0 +1,34 @@
+https://raw.githubusercontent.com/Homebrew/formula-patches/master/autogen/allow-guile-2.2.diff
+
+--- a/agen5/guile-iface.h
++++ b/agen5/guile-iface.h
+@@ -9,7 +9,7 @@
+ # error AutoGen does not work with this version of Guile
+ choke me.
+
+-#elif GUILE_VERSION < 201000
++#else
+ # define AG_SCM_IS_PROC(_p) scm_is_true( scm_procedure_p(_p))
+ # define AG_SCM_LIST_P(_l) scm_is_true( scm_list_p(_l))
+ # define AG_SCM_PAIR_P(_p) scm_is_true( scm_pair_p(_p))
+@@ -24,9 +24,6 @@
+ # define AG_SCM_TO_ULONG(_v) ((unsigned long)scm_to_ulong(_v))
+ # define AG_SCM_VEC_P(_v) scm_is_vector(_v)
+
+-#else
+-# error unknown GUILE_VERSION
+- choke me.
+ #endif
+
+ #endif /* MUTATING_GUILE_IFACE_H_GUARD */
+--- a/configure
++++ b/configure
+@@ -14191,7 +14191,7 @@ $as_echo "no" >&6; }
+ PKG_CONFIG=""
+ fi
+ fi
+- _guile_versions_to_search="2.0 1.8"
++ _guile_versions_to_search="2.2 2.0 1.8"
+ if test -n "$GUILE_EFFECTIVE_VERSION"; then
+ _guile_tmp=""
+ for v in $_guile_versions_to_search; do