summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:52:02 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:52:02 +0200
commit83adec6d70aab693b98a7421e2157bbdd984b431 (patch)
tree5e16c71723a829ddfa3a3b6c1f48c56eb1516c8f /sys-devel/bc
parentsys-apps/duc: drop 1.4.1-r1 (EAPI 5) (diff)
downloadgentoo-83adec6d70aab693b98a7421e2157bbdd984b431.tar.gz
gentoo-83adec6d70aab693b98a7421e2157bbdd984b431.tar.bz2
gentoo-83adec6d70aab693b98a7421e2157bbdd984b431.zip
sys-devel/bc: drop 1.06.95-r2 (EAPI 5)
Closes: https://bugs.gentoo.org/773064 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-devel/bc')
-rw-r--r--sys-devel/bc/Manifest1
-rw-r--r--sys-devel/bc/bc-1.06.95-r2.ebuild61
-rw-r--r--sys-devel/bc/files/bc-1.06.95-mem-leak.patch24
-rw-r--r--sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch13
4 files changed, 0 insertions, 99 deletions
diff --git a/sys-devel/bc/Manifest b/sys-devel/bc/Manifest
index 2c8012c81682..fed58953c5bc 100644
--- a/sys-devel/bc/Manifest
+++ b/sys-devel/bc/Manifest
@@ -1,2 +1 @@
-DIST bc-1.06.95.tar.bz2 290069 BLAKE2B 774f07b1f85b4de7c4707baa355caed5a9fc7b3a5ee1a14f4e9fd59f47a4bbdf34bcb76dc05de4dd8c65615284c3588ad7961fa493ed559a0e8880647835bda0 SHA512 16ec13f87ef76ad4de77d378ef8d65a582adca1bf661c9d7675e78d940680c77e81a00a01817fde7c1ad1524562d6f933caa5c42a0686f3f85aadbb39393afb1
DIST bc-1.07.1.tar.gz 419850 BLAKE2B dcedc193be5521aa0fa3a19746233ed65bc1fe8ef12e15155341706de6fbeecb6dd7ee4ab11e2d4b3aca2ae7097cce89e389b3573493bbc893e00b4ed3239594 SHA512 02126d0db6b6ed06d56cfc292d6f5475ff1e574779d7e69c7809bbb1e13f946f57ea07da2a7666baa092507a951a822044b0970075f75eefe65a5c1999b75d34
diff --git a/sys-devel/bc/bc-1.06.95-r2.ebuild b/sys-devel/bc/bc-1.06.95-r2.ebuild
deleted file mode 100644
index 2b569e4bd4c6..000000000000
--- a/sys-devel/bc/bc-1.06.95-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit epatch flag-o-matic toolchain-funcs
-
-DESCRIPTION="Handy console-based calculator utility"
-HOMEPAGE="https://www.gnu.org/software/bc/bc.html"
-SRC_URI="https://alpha.gnu.org/gnu/bc/${P}.tar.bz2
- mirror://gnu/bc/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="libedit readline static"
-
-RDEPEND="
- !readline? ( libedit? ( dev-libs/libedit:= ) )
- readline? (
- >=sys-libs/readline-4.1:0=
- >=sys-libs/ncurses-5.2:=
- )
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- virtual/yacc
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-void_uninitialized.patch #349339
- epatch "${FILESDIR}"/${P}-mem-leak.patch #264889
-}
-
-src_configure() {
- export CONFIG_SHELL=${BASH}
-
- local libedit
- if use readline ; then
- libedit="--without-libedit"
- else
- libedit=$(use_with libedit)
- fi
- use static && append-ldflags -static
- # Clobber any CONFIG_SHELL setting the user has forced on us.
- # We should be able to delete this w/the next release as it
- # should use updated autoconf.
- CONFIG_SHELL=/bin/bash \
- econf \
- $(use_with readline) \
- ${libedit}
-
- # Do not regen docs -- configure produces a small fragment that includes
- # the version info which causes all pages to regen (newer file). #554774
- touch -r doc doc/*
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
diff --git a/sys-devel/bc/files/bc-1.06.95-mem-leak.patch b/sys-devel/bc/files/bc-1.06.95-mem-leak.patch
deleted file mode 100644
index 13628464b540..000000000000
--- a/sys-devel/bc/files/bc-1.06.95-mem-leak.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://bugs.gentoo.org/264889
-
---- a/bc/bc.y
-+++ b/bc/bc.y
-@@ -569,6 +569,7 @@ expression : named_expression ASSIGN_OP
- generate (">");
- break;
- }
-+ free($2);
- }
- | expression '+' expression
- {
---- a/bc/util.c
-+++ b/bc/util.c
-@@ -602,8 +602,7 @@ lookup (name, namekind)
- case FUNCTDEF:
- if (id->f_name != 0)
- {
-- if (namekind != FUNCT)
-- free(name);
-+ free(name);
- /* Check to see if we are redefining a math lib function. */
- if (use_math && namekind == FUNCTDEF && id->f_name <= 6)
- id->f_name = next_func++;
diff --git a/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch b/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch
deleted file mode 100644
index 3304973f89af..000000000000
--- a/sys-devel/bc/files/bc-1.06.95-void_uninitialized.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://www.pixelbeat.org/programming/oss_bug_flow.html
-https://bugs.gentoo.org/349339
-
---- bc/storage.c
-+++ bc/storage.c
-@@ -99,6 +99,7 @@
- {
- f = &functions[indx];
- f->f_defined = FALSE;
-+ f->f_void = FALSE;
- f->f_body = (char *) bc_malloc (BC_START_SIZE);
- f->f_body_size = BC_START_SIZE;
- f->f_code_size = 0;