summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-30 17:47:19 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-30 17:49:55 -0500
commitc9c48c989410c9aaf6e2cb6b0a51e6551fc97f29 (patch)
tree9d33d443197f6c74857dada8a226b625dadea82f /sys-devel/binutils-config
parentmedia-gfx/fontforge: fix misaligned memory access (diff)
downloadgentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.tar.gz
gentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.tar.bz2
gentoo-c9c48c989410c9aaf6e2cb6b0a51e6551fc97f29.zip
Revert "sys-devel/binutils-config: add avr/msp symlink handling"
This reverts commit 1b129b82462191f6adf022a2327d5b3a72dcb893. This change caused symlinks to go missing under /usr/${CTARGET}/lib for "normal" cross toolchains. Anothoer solution is needed for avr/msp. Closes: https://bugs.gentoo.org/642738
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/binutils-config-5-r4.ebuild (renamed from sys-devel/binutils-config/binutils-config-5-r3.ebuild)0
-rw-r--r--sys-devel/binutils-config/binutils-config-5.1-r1.ebuild (renamed from sys-devel/binutils-config/binutils-config-5.1.ebuild)0
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-58
-rw-r--r--sys-devel/binutils-config/files/binutils-config-5.16
4 files changed, 3 insertions, 11 deletions
diff --git a/sys-devel/binutils-config/binutils-config-5-r3.ebuild b/sys-devel/binutils-config/binutils-config-5-r4.ebuild
index 6a486bdebf46..6a486bdebf46 100644
--- a/sys-devel/binutils-config/binutils-config-5-r3.ebuild
+++ b/sys-devel/binutils-config/binutils-config-5-r4.ebuild
diff --git a/sys-devel/binutils-config/binutils-config-5.1.ebuild b/sys-devel/binutils-config/binutils-config-5.1-r1.ebuild
index ef7b1bd5c11d..ef7b1bd5c11d 100644
--- a/sys-devel/binutils-config/binutils-config-5.1.ebuild
+++ b/sys-devel/binutils-config/binutils-config-5.1-r1.ebuild
diff --git a/sys-devel/binutils-config/files/binutils-config-5 b/sys-devel/binutils-config/files/binutils-config-5
index e6c5fac00264..acb72b7e3435 100755
--- a/sys-devel/binutils-config/files/binutils-config-5
+++ b/sys-devel/binutils-config/files/binutils-config-5
@@ -1,5 +1,5 @@
#!/bin/bash
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Format of /etc/env.d/binutils/:
@@ -145,17 +145,13 @@ switch_profile() {
cd "${ROOT}/${LIBPATH}" || exit 1
if [[ ${TARGET} == ${HOST} ]] ; then
dstlib=${EROOT}/usr/${HOST}/lib
- elif [[ -d ${EROOT}/usr/${TARGET}/lib ]] ; then
- # true for at least avr and msp targets
- dstlib=${EROOT}/usr/${TARGET}/lib
else
dstlib=${EROOT}/usr/${HOST}/${TARGET}/lib
fi
# When upgrading, we need to clean up ldscripts and libs.
# Don't symlink back in the libs -- the binutils-lib package handles
# these now.
- # TODO: Stop requiring even the ldscripts symlink, except
- # we can't for bare-metal toolchains, so... bug #147155
+ # TODO: Stop requiring even the ldscripts symlink.
mkdir -p "${dstlib}"
rm -rf "${ROOT}/${BINPATH_LINKS}"/ldscripts
atomic_ln "${LIBPATH}/ldscripts" "${dstlib}" "ldscripts"
diff --git a/sys-devel/binutils-config/files/binutils-config-5.1 b/sys-devel/binutils-config/files/binutils-config-5.1
index 945295c3e3ad..ec06d47c14a7 100644
--- a/sys-devel/binutils-config/files/binutils-config-5.1
+++ b/sys-devel/binutils-config/files/binutils-config-5.1
@@ -145,17 +145,13 @@ switch_profile() {
cd "${ROOT}/${LIBPATH}" || exit 1
if [[ ${TARGET} == ${HOST} ]] ; then
dstlib=${EROOT}/usr/${HOST}/lib
- elif [[ -d ${EROOT}/usr/${TARGET}/lib ]] ; then
- # true for at least avr and msp targets
- dstlib=${EROOT}/usr/${TARGET}/lib
else
dstlib=${EROOT}/usr/${HOST}/${TARGET}/lib
fi
# When upgrading, we need to clean up ldscripts and libs.
# Don't symlink back in the libs -- the binutils-lib package handles
# these now.
- # TODO: Stop requiring even the ldscripts symlink, except
- # we can't for bare-metal toolchains, so... bug #147155
+ # TODO: Stop requiring even the ldscripts symlink.
mkdir -p "${dstlib}"
rm -rf "${ROOT}/${BINPATH_LINKS}"/ldscripts
atomic_ln "${LIBPATH}/ldscripts" "${dstlib}" "ldscripts"