summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-19 13:49:21 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-19 13:49:36 +0100
commitc9d35add51dc7da383e9f5356638b95378392a96 (patch)
treed7f7124bf58e8f7571ecf6ee6731fd9d82ac44df /sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild
parentdev-perl/Clipboard: Clean up old. (diff)
downloadgentoo-c9d35add51dc7da383e9f5356638b95378392a96.tar.gz
gentoo-c9d35add51dc7da383e9f5356638b95378392a96.tar.bz2
gentoo-c9d35add51dc7da383e9f5356638b95378392a96.zip
sys-devel/binutils-hppa64: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild
new file mode 100644
index 000000000000..ffa35f5bb523
--- /dev/null
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.27.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+export CTARGET=hppa64-${CHOST#*-}
+
+PATCHVER="1.0"
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+DESCRIPTION="binutils package for building 64bit kernels on HPPA"
+
+KEYWORDS="-* ~hppa"
+
+# 66_all_binutils-2.22-warn-textrel.patch fails to apply with
+# patch-2.5.9, so require a version that for sure works
+DEPEND+=" >=sys-devel/patch-2.6.1"
+
+src_install() {
+ toolchain-binutils_src_install
+
+ # tweak the default fake list a little bit
+ cd "${D}"/etc/env.d/binutils
+ sed -i '/FAKE_TARGETS=/s:"$: hppa64-linux":' ${CTARGET}-${BVER} || die
+}