summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 15:43:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:34 +0200
commit3be4a89e9fd6061fbf91f361911cff9079192746 (patch)
treefacb630924e434093fd597a44d18f9f217e74a39 /sys-devel/clang-common
parentsys-devel/lld: Port to py3.9 (diff)
downloadgentoo-3be4a89e9fd6061fbf91f361911cff9079192746.tar.gz
gentoo-3be4a89e9fd6061fbf91f361911cff9079192746.tar.bz2
gentoo-3be4a89e9fd6061fbf91f361911cff9079192746.zip
sys-devel/clang-common: Apply patches in WORKDIR in 10.0.1+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-10.0.1.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-10.0.1_rc1.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-11.0.0.9999.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-10.0.1.9999.ebuild b/sys-devel/clang-common/clang-common-10.0.1.9999.ebuild
index d1bfe71d2f80..6da8d1a30ae7 100644
--- a/sys-devel/clang-common/clang-common-10.0.1.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.1.9999.ebuild
@@ -18,6 +18,11 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
+src_prepare() {
+ cd "${WORKDIR}" || die
+ default
+}
+
src_install() {
newbashcomp bash-autocomplete.sh clang
}
diff --git a/sys-devel/clang-common/clang-common-10.0.1_rc1.ebuild b/sys-devel/clang-common/clang-common-10.0.1_rc1.ebuild
index 18e41e0917da..ca046d28ce0b 100644
--- a/sys-devel/clang-common/clang-common-10.0.1_rc1.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.1_rc1.ebuild
@@ -18,6 +18,11 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
+src_prepare() {
+ cd "${WORKDIR}" || die
+ default
+}
+
src_install() {
newbashcomp bash-autocomplete.sh clang
}
diff --git a/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
index 18e41e0917da..ca046d28ce0b 100644
--- a/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
@@ -18,6 +18,11 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
+src_prepare() {
+ cd "${WORKDIR}" || die
+ default
+}
+
src_install() {
newbashcomp bash-autocomplete.sh clang
}